CVE-2004-1020

medium

Description

The addslashes function in PHP 4.3.9 does not properly escape a NULL (/0) character, which may allow remote attackers to read arbitrary files in PHP applications that contain a directory traversal vulnerability in require or include statements, but are otherwise protected by the magic_quotes_gpc mechanism. NOTE: this issue was originally REJECTed by its CNA before publication, but that decision is in active dispute. This candidate may change significantly in the future as a result of further discussion.

References

https://exchange.xforce.ibmcloud.com/vulnerabilities/18516

http://www.gentoo.org/security/en/glsa/glsa-200412-14.xml

http://www.mandriva.com/security/advisories?name=MDKSA-2004:151

http://www.php.net/release_4_3_10.php

Details

Source: Mitre, NVD

Published: 2005-01-10

Risk Information

CVSS v2

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Severity: Medium