GLSA-201702-29 : PHP: Multiple vulnerabilities

High Nessus Plugin ID 97272


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201702-29 (PHP: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in PHP. Please review the CVE identifiers referenced below for details.
Impact :

An attacker could possibly execute arbitrary code or create a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All PHP 5.6 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/php-5.6.30:5.6'

See Also

Plugin Details

Severity: High

ID: 97272

File Name: gentoo_GLSA-201702-29.nasl

Version: $Revision: 3.3 $

Type: local

Published: 2017/02/21

Modified: 2017/02/27

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:php, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/02/21

Reference Information

CVE: CVE-2016-10158, CVE-2016-10159, CVE-2016-10160, CVE-2016-10161, CVE-2016-9935

GLSA: 201702-29