CVE-2016-9935

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The php_wddx_push_element function in ext/wddx/wddx.c in PHP before 5.6.29 and 7.x before 7.0.14 allows remote attackers to cause a denial of service (out-of-bounds read and memory corruption) or possibly have unspecified other impact via an empty boolean element in a wddxPacket XML document.

References

http://lists.opensuse.org/opensuse-updates/2016-12/msg00142.html

http://lists.opensuse.org/opensuse-updates/2017-01/msg00034.html

http://lists.opensuse.org/opensuse-updates/2017-01/msg00054.html

http://www.debian.org/security/2016/dsa-3737

http://www.openwall.com/lists/oss-security/2016/12/12/2

http://www.php.net/ChangeLog-5.php

http://www.php.net/ChangeLog-7.php

http://www.securityfocus.com/bid/94846

https://access.redhat.com/errata/RHSA-2018:1296

https://bugs.php.net/bug.php?id=73631

https://github.com/php/php-src/commit/66fd44209d5ffcb9b3d1bc1b9fd8e35b485040c0

https://security.gentoo.org/glsa/201702-29

Details

Source: MITRE

Published: 2017-01-04

Updated: 2018-05-04

Type: CWE-125

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (26 total)

IDNameProductFamilySeverity
137966EulerOS Virtualization 3.0.6.0 : php (EulerOS-SA-2020-1747)NessusHuawei Local Security Checks
critical
132184EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2649)NessusHuawei Local Security Checks
critical
131592EulerOS 2.0 SP2 : php (EulerOS-SA-2019-2438)NessusHuawei Local Security Checks
critical
130683EulerOS 2.0 SP5 : php (EulerOS-SA-2019-2221)NessusHuawei Local Security Checks
critical
98838PHP 7.0.x < 7.0.14 php_wddx_push_element() Function Empty Boolean Element Decoding RCEWeb Application ScanningComponent Vulnerability
critical
98819PHP 5.6.x < 5.6.29 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
119990SUSE SLES12 Security Update : php5 (SUSE-SU-2017:0038-1)NessusSuSE Local Security Checks
critical
119989SUSE SLES12 Security Update : php7 (SUSE-SU-2017:0017-1)NessusSuSE Local Security Checks
critical
99134macOS 10.12.x < 10.12.4 Multiple Vulnerabilities (httpoxy)NessusMacOS X Local Security Checks
critical
97566openSUSE Security Update : php5 (openSUSE-2017-308)NessusSuSE Local Security Checks
critical
97521Ubuntu 16.04 LTS / 16.10 : php7.0 regression (USN-3211-2)NessusUbuntu Local Security Checks
critical
97384Ubuntu 16.04 LTS / 16.10 : php7.0 vulnerabilities (USN-3211-1)NessusUbuntu Local Security Checks
critical
97272GLSA-201702-29 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
97190Ubuntu 12.04 LTS / 14.04 LTS : php5 vulnerabilities (USN-3196-1)NessusUbuntu Local Security Checks
critical
97052Debian DLA-818-1 : php5 security updateNessusDebian Local Security Checks
critical
96806Amazon Linux AMI : php70 (ALAS-2017-788)NessusAmazon Linux Local Security Checks
critical
96805Amazon Linux AMI : php56 (ALAS-2017-787)NessusAmazon Linux Local Security Checks
critical
96431SUSE SLES11 Security Update : php53 (SUSE-SU-2017:0109-1)NessusSuSE Local Security Checks
critical
96381openSUSE Security Update : php5 (openSUSE-2017-62)NessusSuSE Local Security Checks
critical
96380openSUSE Security Update : php7 (openSUSE-2017-61)NessusSuSE Local Security Checks
critical
96221FreeBSD : PHP -- multiple vulnerabilities (6972668d-cdb7-11e6-a9a5-b499baebfeaf)NessusFreeBSD Local Security Checks
critical
96130openSUSE Security Update : php5 (openSUSE-2016-1505)NessusSuSE Local Security Checks
critical
96016Debian DSA-3737-1 : php5 - security updateNessusDebian Local Security Checks
critical
95875PHP 7.0.x < 7.0.14 Multiple VulnerabilitiesNessusCGI abuses
critical
95874PHP 5.6.x < 5.6.29 Multiple VulnerabilitiesNessusCGI abuses
critical
95725Slackware 14.0 / 14.1 / 14.2 / current : php (SSA:2016-347-03)NessusSlackware Local Security Checks
critical