CVE-2016-10161

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The object_common1 function in ext/standard/var_unserializer.c in PHP before 5.6.30, 7.0.x before 7.0.15, and 7.1.x before 7.1.1 allows remote attackers to cause a denial of service (buffer over-read and application crash) via crafted serialized data that is mishandled in a finish_nested_data call.

References

http://php.net/ChangeLog-5.php

http://php.net/ChangeLog-7.php

http://www.debian.org/security/2017/dsa-3783

http://www.securityfocus.com/bid/95768

http://www.securitytracker.com/id/1037659

https://access.redhat.com/errata/RHSA-2018:1296

https://bugs.php.net/bug.php?id=73825

https://github.com/php/php-src/commit/16b3003ffc6393e250f069aa28a78dc5a2c064b2

https://security.gentoo.org/glsa/201702-29

https://security.netapp.com/advisory/ntap-20180112-0001/

https://www.tenable.com/security/tns-2017-04

Details

Source: MITRE

Published: 2017-01-24

Updated: 2018-05-04

Type: CWE-125

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (27 total)

IDNameProductFamilySeverity
137966EulerOS Virtualization 3.0.6.0 : php (EulerOS-SA-2020-1747)NessusHuawei Local Security Checks
critical
132184EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2649)NessusHuawei Local Security Checks
critical
130683EulerOS 2.0 SP5 : php (EulerOS-SA-2019-2221)NessusHuawei Local Security Checks
critical
98856PHP 7.1.x < 7.1.1 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98839PHP 7.0.x < 7.0.15 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98821PHP 5.6.x < 5.6.30 Multiple DoSWeb Application ScanningComponent Vulnerability
critical
119994SUSE SLES12 Security Update : php5 (SUSE-SU-2017:0556-1)NessusSuSE Local Security Checks
critical
119993SUSE SLES12 Security Update : php7 (SUSE-SU-2017:0534-1)NessusSuSE Local Security Checks
critical
101050Tenable SecurityCenter PHP < 5.6.30 Multiple Vulnerabilities (TNS-2017-04)NessusMisc.
critical
99134macOS 10.12.x < 10.12.4 Multiple Vulnerabilities (httpoxy)NessusMacOS X Local Security Checks
critical
99039Amazon Linux AMI : php70 (ALAS-2017-812)NessusAmazon Linux Local Security Checks
critical
99035Amazon Linux AMI : php56 (ALAS-2017-808)NessusAmazon Linux Local Security Checks
critical
97726Tenable SecurityCenter 5.x < 5.4.3 Multiple Vulnerabilities (TNS-2017-04) (httpoxy)NessusMisc.
medium
97563openSUSE Security Update : php7 (openSUSE-2017-304)NessusSuSE Local Security Checks
critical
97521Ubuntu 16.04 LTS / 16.10 : php7.0 regression (USN-3211-2)NessusUbuntu Local Security Checks
critical
97431SUSE SLES11 Security Update : php53 (SUSE-SU-2017:0568-1)NessusSuSE Local Security Checks
critical
97384Ubuntu 16.04 LTS / 16.10 : php7.0 vulnerabilities (USN-3211-1)NessusUbuntu Local Security Checks
critical
97272GLSA-201702-29 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
97190Ubuntu 12.04 LTS / 14.04 LTS : php5 vulnerabilities (USN-3196-1)NessusUbuntu Local Security Checks
critical
97103Slackware 14.0 / 14.1 / 14.2 / current : php (SSA:2017-041-03)NessusSlackware Local Security Checks
critical
97068Debian DSA-3783-1 : php5 - security updateNessusDebian Local Security Checks
critical
97052Debian DLA-818-1 : php5 security updateNessusDebian Local Security Checks
critical
9938PHP 7.0.x < 7.0.15 / 7.1.x < 7.1.1 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
critical
96801PHP 7.1.x < 7.1.1 Multiple VulnerabilitiesNessusCGI abuses
critical
96800PHP 7.0.x < 7.0.15 Multiple VulnerabilitiesNessusCGI abuses
critical
96799PHP 5.6.x < 5.6.30 Multiple DoSNessusCGI abuses
critical
9937PHP 5.6.x < 5.6.30 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high