SUSE SLES11 Security Update : openssh (SUSE-SU-2016:2388-1)

High Nessus Plugin ID 93735

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for OpenSSH fixes the following issues :

- Prevent user enumeration through the timing of password processing. (bsc#989363, CVE-2016-6210)

- Allow lowering the DH groups parameter limit in server as well as when GSSAPI key exchange is used.
(bsc#948902)

- Sanitize input for xauth(1). (bsc#970632, CVE-2016-3115)

- Prevent X11 SECURITY circumvention when forwarding X11 connections. (bsc#962313, CVE-2016-1908)

- Disable DH parameters under 2048 bits by default and allow lowering the limit back to the RFC 4419 specified minimum through an option. (bsc#932483, bsc#948902)

- Ignore PAM environment when using login. (bsc#975865, CVE-2015-8325)

- Limit the accepted password length (prevents a possible denial of service). (bsc#992533, CVE-2016-6515)

- Relax version requires for the openssh-askpass sub-package. (bsc#962794)

- Avoid complaining about unset DISPLAY variable.
(bsc#981654)

- Initialize message id to prevent connection breakups in some cases. (bsc#959096)

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE OpenStack Cloud 5:zypper in -t patch sleclo50sp3-openssh-12759=1

SUSE Manager Proxy 2.1:zypper in -t patch slemap21-openssh-12759=1

SUSE Manager 2.1:zypper in -t patch sleman21-openssh-12759=1

SUSE Linux Enterprise Server 11-SP3-LTSS:zypper in -t patch slessp3-openssh-12759=1

SUSE Linux Enterprise Point of Sale 11-SP3:zypper in -t patch sleposp3-openssh-12759=1

SUSE Linux Enterprise Debuginfo 11-SP3:zypper in -t patch dbgsp3-openssh-12759=1

To bring your system up-to-date, use 'zypper patch'.

See Also

https://bugzilla.suse.com/show_bug.cgi?id=932483

https://bugzilla.suse.com/show_bug.cgi?id=948902

https://bugzilla.suse.com/show_bug.cgi?id=959096

https://bugzilla.suse.com/show_bug.cgi?id=962313

https://bugzilla.suse.com/show_bug.cgi?id=962794

https://bugzilla.suse.com/show_bug.cgi?id=970632

https://bugzilla.suse.com/show_bug.cgi?id=975865

https://bugzilla.suse.com/show_bug.cgi?id=981654

https://bugzilla.suse.com/show_bug.cgi?id=989363

https://bugzilla.suse.com/show_bug.cgi?id=992533

https://www.suse.com/security/cve/CVE-2015-8325/

https://www.suse.com/security/cve/CVE-2016-1908/

https://www.suse.com/security/cve/CVE-2016-3115/

https://www.suse.com/security/cve/CVE-2016-6210/

https://www.suse.com/security/cve/CVE-2016-6515/

http://www.nessus.org/u?9a55375c

Plugin Details

Severity: High

ID: 93735

File Name: suse_SU-2016-2388-1.nasl

Version: 2.8

Type: local

Agent: unix

Published: 2016/09/27

Updated: 2019/09/11

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.8

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:openssh, p-cpe:/a:novell:suse_linux:openssh-askpass, p-cpe:/a:novell:suse_linux:openssh-askpass-gnome, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/09/26

Vulnerability Publication Date: 2016/03/22

Reference Information

CVE: CVE-2015-8325, CVE-2016-1908, CVE-2016-3115, CVE-2016-6210, CVE-2016-6515