CVE-2015-8325

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The do_setup_env function in session.c in sshd in OpenSSH through 7.2p2, when the UseLogin feature is enabled and PAM is configured to read .pam_environment files in user home directories, allows local users to gain privileges by triggering a crafted environment for the /bin/login program, as demonstrated by an LD_PRELOAD environment variable.

References

http://rhn.redhat.com/errata/RHSA-2016-2588.html

http://rhn.redhat.com/errata/RHSA-2017-0641.html

http://www.debian.org/security/2016/dsa-3550

http://www.securityfocus.com/bid/86187

http://www.securitytracker.com/id/1036487

https://anongit.mindrot.org/openssh.git/commit/?id=85bdcd7c92fe7ff133bbc4e10a65c91810f88755

https://bugzilla.redhat.com/show_bug.cgi?id=1328012

https://people.canonical.com/~ubuntu-security/cve/2015/CVE-2015-8325.html

https://security.gentoo.org/glsa/201612-18

https://security.netapp.com/advisory/ntap-20180628-0001/

https://security-tracker.debian.org/tracker/CVE-2015-8325

Details

Source: MITRE

Published: 2016-05-01

Updated: 2018-06-30

Type: CWE-264

Risk Information

CVSS v2

Base Score: 7.2

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 3.9

Severity: HIGH

CVSS v3

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH

Tenable Plugins

View all (31 total)

IDNameProductFamilySeverity
130514Juniper JSA10940NessusJunos Local Security Checks
high
127415NewStart CGSL MAIN 4.05 : openssh-latest Multiple Vulnerabilities (NS-SA-2019-0146)NessusNewStart CGSL Local Security Checks
high
127401NewStart CGSL MAIN 4.05 : openssh Multiple Vulnerabilities (NS-SA-2019-0139)NessusNewStart CGSL Local Security Checks
high
105401F5 Networks BIG-IP : OpenSSH vulnerability (K20911042)NessusF5 Networks Local Security Checks
high
99815EulerOS 2.0 SP1 : openssh (EulerOS-SA-2016-1053)NessusHuawei Local Security Checks
high
99221Scientific Linux Security Update : openssh on SL6.x i386/x86_64 (20170321)NessusScientific Linux Local Security Checks
high
99080OracleVM 3.3 / 3.4 : openssh (OVMSA-2017-0053)NessusOracleVM Local Security Checks
high
99067Oracle Linux 6 : openssh (ELSA-2017-0641)NessusOracle Linux Local Security Checks
high
97955CentOS 6 : openssh (CESA-2017:0641)NessusCentOS Local Security Checks
high
97878RHEL 6 : openssh (RHSA-2017:0641)NessusRed Hat Local Security Checks
high
95851Scientific Linux Security Update : openssh on SL7.x x86_64 (20161103)NessusScientific Linux Local Security Checks
high
95604GLSA-201612-18 : OpenSSH: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
95477AIX OpenSSH Advisory : openssh_advisory9.ascNessusAIX Local Security Checks
high
95334CentOS 7 : openssh (CESA-2016:2588)NessusCentOS Local Security Checks
high
94976Amazon Linux AMI : openssh (ALAS-2016-770)NessusAmazon Linux Local Security Checks
high
94709Oracle Linux 7 : openssh (ELSA-2016-2588)NessusOracle Linux Local Security Checks
high
94551RHEL 7 : openssh (RHSA-2016:2588)NessusRed Hat Local Security Checks
high
93735SUSE SLES11 Security Update : openssh (SUSE-SU-2016:2388-1)NessusSuSE Local Security Checks
critical
93267FreeBSD : openssh -- sshd -- remote valid user discovery and PAM /bin/login attack (adccefd1-7080-11e6-a2cb-c80aa9043978)NessusFreeBSD Local Security Checks
high
93194OpenSSH < 7.3 Multiple VulnerabilitiesNessusMisc.
high
9507OpenSSH 7.x < 7.3 Multiple VulnerabilitiesNessus Network MonitorSSH
high
92760Slackware 13.0 / 13.1 / 13.37 / 14.0 / 14.1 / 14.2 / current : openssh (SSA:2016-219-03)NessusSlackware Local Security Checks
high
92172Fedora 23 : gsi-openssh (2016-d31c00ca51)NessusFedora Local Security Checks
high
92162Fedora 24 : openssh (2016-cce03cc497)NessusFedora Local Security Checks
high
92130Fedora 24 : gsi-openssh (2016-99c6bc92df)NessusFedora Local Security Checks
high
91655SUSE SLES11 Security Update : openssh (SUSE-SU-2016:1528-1)NessusSuSE Local Security Checks
critical
91413openSUSE Security Update : openssh (openSUSE-2016-668)NessusSuSE Local Security Checks
critical
91318SUSE SLED12 / SLES12 Security Update : openssh (SUSE-SU-2016:1386-1)NessusSuSE Local Security Checks
critical
91086Ubuntu 12.04 LTS / 14.04 LTS / 15.10 : openssh vulnerabilities (USN-2966-1)NessusUbuntu Local Security Checks
critical
90694Fedora 23 : openssh-7.2p2-3.fc23 (2016-7f5004093e)NessusFedora Local Security Checks
high
90550Debian DSA-3550-1 : openssh - security updateNessusDebian Local Security Checks
high