SUSE SLED11 / SLES11 Security Update : postgresql91 (SUSE-SU-2015:1091-1)

Medium Nessus Plugin ID 84338


The remote SUSE host is missing one or more security updates.


This update provides PostgreSQL 9.1.18, which brings fixes for security issues and other enhancements.

The following vulnerabilities have been fixed :

CVE-2015-3165: Avoid possible crash when client disconnects.

CVE-2015-3166: Consistently check for failure of the *printf().

CVE-2015-3167: In contrib/pgcrypto, uniformly report decryption failures. (bsc#931974)

For a comprehensive list of changes, please refer to <a href=''>h ttp://</a>.

This update also includes changes in PostgreSQL's packaging to prepare for the migration to the new major version 9.4. (FATE#316970, bsc#907651)

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Manager Server :

zypper in -t patch sleman21-postgresql91-201505=10760

SUSE Linux Enterprise Software Development Kit 11 SP3 :

zypper in -t patch sdksp3-postgresql91-201505=10760

SUSE Linux Enterprise Server 11 SP3 for VMware :

zypper in -t patch slessp3-postgresql91-201505=10760

SUSE Linux Enterprise Server 11 SP3 :

zypper in -t patch slessp3-postgresql91-201505=10760

SUSE Linux Enterprise Desktop 11 SP3 :

zypper in -t patch sledsp3-postgresql91-201505=10760

To bring your system up-to-date, use 'zypper patch'.

See Also'</a

Plugin Details

Severity: Medium

ID: 84338

File Name: suse_SU-2015-1091-1.nasl

Version: $Revision: 2.11 $

Type: local

Agent: unix

Published: 2015/06/23

Modified: 2016/05/11

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:postgresql91, p-cpe:/a:novell:suse_linux:postgresql91-contrib, p-cpe:/a:novell:suse_linux:postgresql91-docs, p-cpe:/a:novell:suse_linux:postgresql91-server, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/06/19

Reference Information

CVE: CVE-2015-3165, CVE-2015-3166, CVE-2015-3167

BID: 74787, 74789, 74790

OSVDB: 122456, 122457, 122458