CVE-2015-3165

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Double free vulnerability in PostgreSQL before 9.0.20, 9.1.x before 9.1.16, 9.2.x before 9.2.11, 9.3.x before 9.3.7, and 9.4.x before 9.4.2 allows remote attackers to cause a denial of service (crash) by closing an SSL session at a time when the authentication timeout will expire during the session shutdown sequence.

References

http://lists.apple.com/archives/security-announce/2015/Sep/msg00004.html

http://rhn.redhat.com/errata/RHSA-2015-1194.html

http://rhn.redhat.com/errata/RHSA-2015-1195.html

http://rhn.redhat.com/errata/RHSA-2015-1196.html

http://www.debian.org/security/2015/dsa-3269

http://www.debian.org/security/2015/dsa-3270

http://www.postgresql.org/about/news/1587/

http://www.postgresql.org/docs/9.0/static/release-9-0-20.html

http://www.postgresql.org/docs/9.1/static/release-9-1-16.html

http://www.postgresql.org/docs/9.2/static/release-9-2-11.html

http://www.postgresql.org/docs/9.3/static/release-9-3-7.html

http://www.postgresql.org/docs/9.4/static/release-9-4-2.html

http://www.securityfocus.com/bid/74787

http://www.ubuntu.com/usn/USN-2621-1

https://security.gentoo.org/glsa/201507-20

https://support.apple.com/HT205219

Details

Source: MITRE

Published: 2015-05-28

Updated: 2018-01-05

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:*

cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:*

cpe:2.3:o:canonical:ubuntu_linux:14.10:*:*:*:*:*:*:*

cpe:2.3:o:canonical:ubuntu_linux:15.04:*:*:*:*:*:*:*

cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*

cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*

Configuration 2

OR

cpe:2.3:o:apple:mac_os_x_server:5.0.2:*:*:*:*:*:*:*

Configuration 3

OR

cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:* versions up to 9.0.19 (inclusive)

cpe:2.3:a:postgresql:postgresql:9.1:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.1:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.2:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.3:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.4:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.5:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.6:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.7:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.8:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.9:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.10:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.11:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.12:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.13:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.14:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.15:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.1:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.2:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.3:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.4:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.5:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.6:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.7:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.8:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.9:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.10:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.3:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.3.1:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.3.2:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.3.3:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.3.4:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.3.5:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.3.6:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.4.0:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.4.1:*:*:*:*:*:*:*

Tenable Plugins

View all (19 total)

IDNameProductFamilySeverity
86066Mac OS X : OS X Server < 5.0.3 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
critical
84960Puppet Enterprise 3.x < 3.8.1 Multiple Vulnerabilities (Logjam)NessusCGI abuses
critical
84896SUSE SLED12 / SLES12 Security Update : postgresql93 (SUSE-SU-2015:1264-1)NessusSuSE Local Security Checks
critical
84863GLSA-201507-20 : PostgreSQL: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
8796PostgreSQL 9.0 < 9.0.20 / 9.1 < 9.1.16 / 9.2 < 9.2.11 / 9.3 < 9.3.7 / 9.4 < 9.4.2 Multiple VulnerabilitiesNessus Network MonitorDatabase
medium
84592Amazon Linux AMI : postgresql8 (ALAS-2015-556)NessusAmazon Linux Local Security Checks
critical
84540Scientific Linux Security Update : postgresql on SL6.x, SL7.x i386/x86_64 (20150629)NessusScientific Linux Local Security Checks
critical
84466RHEL 6 / 7 : postgresql (RHSA-2015:1194)NessusRed Hat Local Security Checks
critical
84464Oracle Linux 6 / 7 : postgresql (ELSA-2015-1194)NessusOracle Linux Local Security Checks
critical
84446CentOS 6 / 7 : postgresql (CESA-2015:1194)NessusCentOS Local Security Checks
critical
84338SUSE SLED11 / SLES11 Security Update : postgresql91 (SUSE-SU-2015:1091-1)NessusSuSE Local Security Checks
critical
84247Amazon Linux AMI : postgresql93 (ALAS-2015-546)NessusAmazon Linux Local Security Checks
medium
84246Amazon Linux AMI : postgresql92 (ALAS-2015-545)NessusAmazon Linux Local Security Checks
medium
83905Debian DLA-227-1 : postgresql-8.4 updateNessusDebian Local Security Checks
critical
83862Ubuntu 12.04 LTS / 14.04 LTS / 14.10 / 15.04 : postgresql-9.1, postgresql-9.3, postgresql-9.4 vulnerabilities (USN-2621-1)NessusUbuntu Local Security Checks
critical
83818PostgreSQL 9.0 < 9.0.20 / 9.1 < 9.1.16 / 9.2 < 9.2.11 / 9.3 < 9.3.7 / 9.4 < 9.4.2 Multiple VulnerabilitiesNessusDatabases
critical
83799FreeBSD : PostgreSQL -- minor security problems. (fc38cd83-00b3-11e5-8ebd-0026551a22dc)NessusFreeBSD Local Security Checks
critical
83787Debian DSA-3270-1 : postgresql-9.4 - security updateNessusDebian Local Security Checks
critical
83786Debian DSA-3269-1 : postgresql-9.1 - security updateNessusDebian Local Security Checks
critical