CVE-2015-3167

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

contrib/pgcrypto in PostgreSQL before 9.0.20, 9.1.x before 9.1.16, 9.2.x before 9.2.11, 9.3.x before 9.3.7, and 9.4.x before 9.4.2 uses different error responses when an incorrect key is used, which makes it easier for attackers to obtain the key via a brute force attack.

References

http://ubuntu.com/usn/usn-2621-1

http://www.debian.org/security/2015/dsa-3269

http://www.debian.org/security/2015/dsa-3270

http://www.postgresql.org/about/news/1587/

http://www.postgresql.org/docs/9.0/static/release-9-0-20.html

http://www.postgresql.org/docs/9.1/static/release-9-1-16.html

http://www.postgresql.org/docs/9.2/static/release-9-2-11.html

http://www.postgresql.org/docs/9.3/static/release-9-3-7.html

http://www.postgresql.org/docs/9.4/static/release-9-4-2.html

Details

Source: MITRE

Published: 2019-11-20

Updated: 2019-11-22

Type: CWE-200

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (17 total)

IDNameProductFamilySeverity
86066Mac OS X : OS X Server < 5.0.3 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
critical
84960Puppet Enterprise 3.x < 3.8.1 Multiple Vulnerabilities (Logjam)NessusCGI abuses
critical
84896SUSE SLED12 / SLES12 Security Update : postgresql93 (SUSE-SU-2015:1264-1)NessusSuSE Local Security Checks
critical
84863GLSA-201507-20 : PostgreSQL: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
8796PostgreSQL 9.0 < 9.0.20 / 9.1 < 9.1.16 / 9.2 < 9.2.11 / 9.3 < 9.3.7 / 9.4 < 9.4.2 Multiple VulnerabilitiesNessus Network MonitorDatabase
medium
84592Amazon Linux AMI : postgresql8 (ALAS-2015-556)NessusAmazon Linux Local Security Checks
critical
84540Scientific Linux Security Update : postgresql on SL6.x, SL7.x i386/x86_64 (20150629)NessusScientific Linux Local Security Checks
critical
84466RHEL 6 / 7 : postgresql (RHSA-2015:1194)NessusRed Hat Local Security Checks
critical
84464Oracle Linux 6 / 7 : postgresql (ELSA-2015-1194)NessusOracle Linux Local Security Checks
critical
84446CentOS 6 / 7 : postgresql (CESA-2015:1194)NessusCentOS Local Security Checks
critical
84338SUSE SLED11 / SLES11 Security Update : postgresql91 (SUSE-SU-2015:1091-1)NessusSuSE Local Security Checks
critical
83905Debian DLA-227-1 : postgresql-8.4 updateNessusDebian Local Security Checks
critical
83862Ubuntu 12.04 LTS / 14.04 LTS / 14.10 / 15.04 : postgresql-9.1, postgresql-9.3, postgresql-9.4 vulnerabilities (USN-2621-1)NessusUbuntu Local Security Checks
critical
83818PostgreSQL 9.0 < 9.0.20 / 9.1 < 9.1.16 / 9.2 < 9.2.11 / 9.3 < 9.3.7 / 9.4 < 9.4.2 Multiple VulnerabilitiesNessusDatabases
critical
83799FreeBSD : PostgreSQL -- minor security problems. (fc38cd83-00b3-11e5-8ebd-0026551a22dc)NessusFreeBSD Local Security Checks
critical
83787Debian DSA-3270-1 : postgresql-9.4 - security updateNessusDebian Local Security Checks
critical
83786Debian DSA-3269-1 : postgresql-9.1 - security updateNessusDebian Local Security Checks
critical