MySQL 5.5.x < 5.5.43 / 5.6.x < 5.6.24 Multiple DoS Vulnerabilities (April 2015 CPU)

Medium Nessus Plugin ID 82800

Synopsis

The remote database server is affected by multiple denial of service vulnerabilities.

Description

The version of MySQL running on the remote host is version 5.5.x prior to 5.5.43 or version 5.6.x prior to 5.6.24. It is, therefore, potentially affected by unspecified flaws in the following MySQL subcomponents that allow a denial of service by an authenticated, remote attacker :

- Replication (CVE-2015-0498)
- Federated (CVE-2015-0499)
- Information Schema (CVE-2015-0500)
- Compiling (CVE-2015-0501)
- Partition (CVE-2015-0503)
- DDL (CVE-2015-0505)
- InnoDB (CVE-2015-0506, CVE-2015-0508)
- Memcached (CVE-2015-0507)
- SP (CVE-2015-0511)
- Security : Privileges (CVE-2015-2567)
- Optimizer (CVE-2015-2571)

Solution

Upgrade to MySQL version 5.5.43 / 5.6.24 or later as referenced in the Oracle April 2015 Critical Patch Update advisory.

See Also

http://www.nessus.org/u?915d056a

Plugin Details

Severity: Medium

ID: 82800

File Name: mysql_5_6_24.nasl

Version: 1.9

Type: remote

Family: Databases

Published: 2015/04/15

Updated: 2018/11/15

Dependencies: 91823, 10719

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.7

Temporal Score: 4.2

Vector: CVSS2#AV:N/AC:M/Au:M/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/04/14

Vulnerability Publication Date: 2015/04/14

Reference Information

CVE: CVE-2015-0498, CVE-2015-0499, CVE-2015-0500, CVE-2015-0501, CVE-2015-0503, CVE-2015-0505, CVE-2015-0506, CVE-2015-0507, CVE-2015-0508, CVE-2015-0511, CVE-2015-2567, CVE-2015-2571

BID: 74070, 74081, 74086, 74095, 74102, 74112, 74115, 74120, 74121, 74123, 74130, 74133