MySQL 5.5 < 5.5.29 Multiple Vulnerabilities

High Nessus Plugin ID 63618

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL 5.5 installed on the remote host is earlier than 5.5.29 and is, therefore, affected by vulnerabilities in the following components :

- Information Schema
- InnoDB
- MyISAM
- Server
- Server Locking
- Server Optimizer
- Server Parser
- Server Partition
- Server Privileges
- Server Replication
- Stored Procedure

Solution

Upgrade to MySQL version 5.5.29 or later.

See Also

http://dev.mysql.com/doc/refman/5.5/en/news-5-5-29.html

http://www.nessus.org/u?4ff06601

Plugin Details

Severity: High

ID: 63618

File Name: mysql_5_5_29.nasl

Version: 1.10

Type: remote

Family: Databases

Published: 2013/01/18

Updated: 2018/11/15

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9

Temporal Score: 7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/01/15

Vulnerability Publication Date: 2012/12/01

Reference Information

CVE: CVE-2012-0572, CVE-2012-0574, CVE-2012-0578, CVE-2012-1702, CVE-2012-1705, CVE-2012-5096, CVE-2012-5611, CVE-2012-5612, CVE-2013-0367, CVE-2013-0368, CVE-2013-0371, CVE-2013-0375, CVE-2013-0383, CVE-2013-0384, CVE-2013-0385, CVE-2013-0386, CVE-2013-0389

BID: 56768, 56769, 57334, 57385, 57388, 57391, 57397, 57400, 57405, 57408, 57410, 57412, 57414, 57415, 57416, 57417, 57418

EDB-ID: 23075, 23076