MariaDB 5.1 < 5.1.66 Buffer Overflow

high Nessus Plugin ID 63147


The remote database server is affected by a buffer overflow vulnerability.


The version of MariaDB 5.1 running on the remote host is prior to 5.1.66. It is, therefore, affected by a buffer overflow vulnerability.
A remote, authenticated attacker could exploit this to execute arbitrary code.


Upgrade to MariaDB version 5.1.66 or later.

See Also

Plugin Details

Severity: High

ID: 63147

File Name: mariadb_5_1_66.nasl

Version: 1.15

Type: remote

Family: Databases

Published: 12/4/2012

Updated: 11/18/2022

Configuration: Enable paranoid mode

Supported Sensors: Frictionless Assessment Agent, Nessus

Risk Information


Risk Factor: High

Score: 7.4


Risk Factor: High

Base Score: 9

Temporal Score: 7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2012-3163

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 11/29/2012

Vulnerability Publication Date: 11/29/2012

Reference Information

CVE: CVE-2012-0540, CVE-2012-1689, CVE-2012-1734, CVE-2012-3150, CVE-2012-3158, CVE-2012-3160, CVE-2012-3163, CVE-2012-3166, CVE-2012-3167, CVE-2012-3173, CVE-2012-3177, CVE-2012-3180, CVE-2012-3197, CVE-2012-4414, CVE-2012-5060, CVE-2012-5611, CVE-2013-1548

BID: 56769