PHP 5.3 < 5.3.3 Multiple Vulnerabilities

high Nessus Plugin ID 48245
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server uses a version of PHP that is affected by multiple flaws.


According to its banner, the version of PHP 5.3 installed on the remote host is older than 5.3.3. Such versions may be affected by several security issues :

- An error exists when processing invalid XML-RPC requests that can lead to a NULL pointer dereference. (bug #51288) (CVE-2010-0397)

- An error exists in the function 'shm_put_var' that is related to resource destruction.

- An error exists in the function 'fnmatch' that can lead to stack exhaustion. (CVE-2010-1917)

- A memory corruption error exists related to call-time pass by reference and callbacks.

- The dechunking filter is vulnerable to buffer overflow.

- An error exists in the sqlite extension that could allow arbitrary memory access.

- An error exists in the 'phar' extension related to string format validation.

- The functions 'mysqlnd_list_fields' and 'mysqlnd_change_user' are vulnerable to buffer overflow.

- The Mysqlnd extension is vulnerable to buffer overflow attack when handling error packets.

- The following functions are not properly protected against function interruptions :

addcslashes, chunk_split, html_entity_decode, iconv_mime_decode, iconv_substr, iconv_mime_encode, htmlentities, htmlspecialchars, str_getcsv, http_build_query, strpbrk, strtr, str_pad, str_word_count, wordwrap, strtok, setcookie, strip_tags, trim, ltrim, rtrim, substr_replace, parse_str, pack, unpack, uasort, preg_match, strrchr (CVE-2010-1860, CVE-2010-1862, CVE-2010-1864, CVE-2010-2097, CVE-2010-2100, CVE-2010-2101, CVE-2010-2190, CVE-2010-2191, CVE-2010-2484)

- The following opcodes are not properly protected against function interruptions :


- The default session serializer contains an error that can be exploited when assigning session variables having user defined names. Arbitrary serialized values can be injected into sessions by including the PS_UNDEF_MARKER, '!', character in variable names.

- A use-after-free error exists in the function 'spl_object_storage_attach'. (CVE-2010-2225)

- An information disclosure vulnerability exists in the function 'var_export' when handling certain error conditions. (CVE-2010-2531)


Upgrade to PHP version 5.3.3 or later.

See Also

Plugin Details

Severity: High

ID: 48245

File Name: php_5_3_3.nasl

Version: 1.21

Type: remote

Family: CGI abuses

Published: 8/4/2010

Updated: 1/19/2021

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2007-1581


Risk Factor: Medium

Score: 6.7


Risk Factor: High

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 7/22/2010

Vulnerability Publication Date: 7/27/2010

Reference Information

CVE: CVE-2010-0397, CVE-2010-1917, CVE-2010-2531, CVE-2010-3065, CVE-2010-2225, CVE-2010-2484, CVE-2010-3062, CVE-2010-3063, CVE-2010-3064, CVE-2010-1860, CVE-2010-2190, CVE-2007-1581, CVE-2010-1862, CVE-2010-1864, CVE-2010-2097, CVE-2010-2100, CVE-2010-2101, CVE-2010-2191

BID: 38708, 41991, 40948, 40461

Secunia: 39675, 40268