CVE-2010-2484

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The strrchr function in PHP 5.2 before 5.2.14 allows context-dependent attackers to obtain sensitive information (memory contents) or trigger memory corruption by causing a userspace interruption of an internal function or handler.

References

http://lists.apple.com/archives/security-announce/2010//Aug/msg00003.html

http://lists.apple.com/archives/security-announce/2010//Nov/msg00000.html

http://lists.opensuse.org/opensuse-security-announce/2010-10/msg00000.html

http://marc.info/?l=bugtraq&m=133469208622507&w=2

http://support.apple.com/kb/HT4312

http://support.apple.com/kb/HT4435

http://www.php.net/releases/5_2_14.php

https://bugzilla.redhat.com/show_bug.cgi?id=619324

Details

Source: MITRE

Published: 2010-08-20

Updated: 2016-08-23

Type: CWE-200

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

Tenable Plugins

View all (12 total)

IDNameProductFamilySeverity
56554Ubuntu 8.04 LTS / 10.04 LTS / 10.10 / 11.04 / 11.10 : php5 vulnerabilities (USN-1231-1)NessusUbuntu Local Security Checks
high
56459GLSA-201110-06 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
50890SuSE 11 / 11.1 Security Update : Apache 2 (SAT Patch Numbers 2880 / 2881)NessusSuSE Local Security Checks
high
50549Mac OS X Multiple Vulnerabilities (Security Update 2010-007)NessusMacOS X Local Security Checks
high
49830SuSE 10 Security Update : Linux kernel (ZYPP Patch Number 7110)NessusSuSE Local Security Checks
high
49752openSUSE Security Update : apache2-mod_php5 (openSUSE-SU-2010:0678-1)NessusSuSE Local Security Checks
high
48424Mac OS X Multiple Vulnerabilities (Security Update 2010-005)NessusMacOS X Local Security Checks
high
48245PHP 5.3 < 5.3.3 Multiple VulnerabilitiesNessusCGI abuses
high
48244PHP 5.2 < 5.2.14 Multiple VulnerabilitiesNessusCGI abuses
high
48197Mandriva Linux Security Advisory : php (MDVSA-2010:139)NessusMandriva Local Security Checks
high
801070PHP < 5.3.3 / 5.2.14 Multiple VulnerabilitiesLog Correlation EngineWeb Servers
high
5616PHP < 5.2.14 / 5.3.x < 5.3.3 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high