CVE-2010-3065

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The default session serializer in PHP 5.2 through 5.2.13 and 5.3 through 5.3.2 does not properly handle the PS_UNDEF_MARKER marker, which allows context-dependent attackers to modify arbitrary session variables via a crafted session variable name.

References

http://lists.opensuse.org/opensuse-security-announce/2010-09/msg00006.html

http://lists.opensuse.org/opensuse-security-announce/2010-10/msg00000.html

http://php-security.org/2010/05/31/mops-2010-060-php-session-serializer-session-data-injection-vulnerability/index.html

http://secunia.com/advisories/42410

http://www.debian.org/security/2010/dsa-2089

http://www.redhat.com/support/errata/RHSA-2010-0919.html

http://www.vupen.com/english/advisories/2010/3081

Details

Source: MITRE

Published: 2010-08-20

Updated: 2010-12-10

Type: CWE-264

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

Tenable Plugins

View all (14 total)

IDNameProductFamilySeverity
75429openSUSE Security Update : apache2-mod_php5 (openSUSE-SU-2010:0599-1)NessusSuSE Local Security Checks
high
68150Oracle Linux 4 / 5 : php (ELSA-2010-0919)NessusOracle Linux Local Security Checks
medium
60908Scientific Linux Security Update : php on SL4.x, SL5.x i386/x86_64NessusScientific Linux Local Security Checks
medium
56459GLSA-201110-06 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
50890SuSE 11 / 11.1 Security Update : Apache 2 (SAT Patch Numbers 2880 / 2881)NessusSuSE Local Security Checks
high
50862CentOS 4 / 5 : php (CESA-2010:0919)NessusCentOS Local Security Checks
medium
50841RHEL 4 / 5 : php (RHSA-2010:0919)NessusRed Hat Local Security Checks
medium
49830SuSE 10 Security Update : Linux kernel (ZYPP Patch Number 7110)NessusSuSE Local Security Checks
high
49752openSUSE Security Update : apache2-mod_php5 (openSUSE-SU-2010:0678-1)NessusSuSE Local Security Checks
high
49306Ubuntu 6.06 LTS / 8.04 LTS / 9.04 / 9.10 / 10.04 LTS : php5 vulnerabilities (USN-989-1)NessusUbuntu Local Security Checks
high
49210openSUSE Security Update : apache2-mod_php5 (openSUSE-SU-2010:0599-1)NessusSuSE Local Security Checks
high
48384Debian DSA-2089-1 : php5 - several vulnerabilitiesNessusDebian Local Security Checks
high
48245PHP 5.3 < 5.3.3 Multiple VulnerabilitiesNessusCGI abuses
high
48244PHP 5.2 < 5.2.14 Multiple VulnerabilitiesNessusCGI abuses
high