FreeBSD : linux-flashplugin -- multiple vulnerabilities (144e524a-77eb-11df-ae06-001b2134ef46)

High Nessus Plugin ID 47025


The remote FreeBSD host is missing one or more security-related updates.


Adobe Product Security Incident Response Team reports :

Critical vulnerabilities have been identified in Adobe Flash Player version and earlier. These vulnerabilities could cause the application to crash and could potentially allow an attacker to take control of the affected system.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 47025

File Name: freebsd_pkg_144e524a77eb11dfae06001b2134ef46.nasl

Version: $Revision: 1.32 $

Type: local

Published: 2010/06/16

Modified: 2014/10/24

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:linux-f10-flashplugin, p-cpe:/a:freebsd:freebsd:linux-f8-flashplugin, p-cpe:/a:freebsd:freebsd:linux-flashplugin, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/06/14

Vulnerability Publication Date: 2008/10/02

Exploitable With


Core Impact

Metasploit (Adobe Flash Player "newfunction" Invalid Pointer Use)

ExploitHub (EH-11-164)

Reference Information

CVE: CVE-2008-4546, CVE-2009-3793, CVE-2010-1297, CVE-2010-2160, CVE-2010-2161, CVE-2010-2162, CVE-2010-2163, CVE-2010-2164, CVE-2010-2165, CVE-2010-2166, CVE-2010-2167, CVE-2010-2169, CVE-2010-2170, CVE-2010-2171, CVE-2010-2172, CVE-2010-2173, CVE-2010-2174, CVE-2010-2175, CVE-2010-2176, CVE-2010-2177, CVE-2010-2178, CVE-2010-2179, CVE-2010-2180, CVE-2010-2181, CVE-2010-2182, CVE-2010-2183, CVE-2010-2184, CVE-2010-2185, CVE-2010-2186, CVE-2010-2187, CVE-2010-2188, CVE-2010-2189

CWE: 399