SuSE 10 Security Update : PHP5 (ZYPP Patch Number 3290)

High Nessus Plugin ID 29378


The remote SuSE 10 host is missing a security-related patch.


This Update fixes numerous vulnerabilities in PHP. Most of them were made public during the 'Month of PHP Bugs'. The vulnerabilities potentially lead to crashes, information leaks or even execution of malicious code.

CVE-2007-1380 / CVE-2007-0988 / CVE-2007-1375 / CVE-2007-1521 / CVE-2007-1376 / CVE-2007-1583 / CVE-2007-1461 / CVE-2007-1484 / CVE-2007-1700 / CVE-2007-1717 / CVE-2007-1718 / CVE-2007-1001 / CVE-2007-1824


Apply ZYPP patch number 3290.

See Also

Plugin Details

Severity: High

ID: 29378

File Name: suse_apache2-mod_php5-3290.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2007/12/13

Modified: 2012/05/17

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:N/A:N

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2007/05/08

Reference Information

CVE: CVE-2007-0988, CVE-2007-1001, CVE-2007-1375, CVE-2007-1376, CVE-2007-1380, CVE-2007-1461, CVE-2007-1484, CVE-2007-1521, CVE-2007-1583, CVE-2007-1700, CVE-2007-1717, CVE-2007-1718, CVE-2007-1824

CWE: 399