CVE-2007-1484

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The array_user_key_compare function in PHP 4.4.6 and earlier, and 5.x up to 5.2.1, makes erroneous calls to zval_dtor, which triggers memory corruption and allows local users to bypass safe_mode and execute arbitrary code via a certain unset operation after array_user_key_compare has been called.

References

http://docs.info.apple.com/article.html?artnum=306172

http://lists.apple.com/archives/security-announce//2007/Jul/msg00004.html

http://secunia.com/advisories/24542

http://secunia.com/advisories/25056

http://secunia.com/advisories/25057

http://secunia.com/advisories/25445

http://secunia.com/advisories/26235

http://security.gentoo.org/glsa/glsa-200705-19.xml

http://us2.php.net/releases/4_4_7.php

http://us2.php.net/releases/5_2_2.php

http://www.novell.com/linux/security/advisories/2007_32_php.html

http://www.php-security.org/MOPB/MOPB-24-2007.html

http://www.securityfocus.com/bid/22990

http://www.securityfocus.com/bid/25159

http://www.ubuntu.com/usn/usn-455-1

http://www.vupen.com/english/advisories/2007/2732

Details

Source: MITRE

Published: 2007-03-16

Updated: 2018-10-19

Risk Information

CVSS v2

Base Score: 4.6

Vector: AV:L/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 3.9

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:php:php:*:*:*:*:*:*:*:* versions up to 4.4.6 (inclusive)

cpe:2.3:a:php:php:*:*:*:*:*:*:*:* versions from 5.0.0 to 5.2.1 (inclusive)

Tenable Plugins

View all (10 total)

IDNameProductFamilySeverity
29378SuSE 10 Security Update : PHP5 (ZYPP Patch Number 3290)NessusSuSE Local Security Checks
high
28053Ubuntu 6.06 LTS / 6.10 / 7.04 : php5 vulnerabilities (USN-455-1)NessusUbuntu Local Security Checks
high
27150openSUSE 10 Security Update : apache2-mod_php5 (apache2-mod_php5-3289)NessusSuSE Local Security Checks
high
25830Mac OS X Multiple Vulnerabilities (Security Update 2007-007)NessusMacOS X Local Security Checks
critical
25340GLSA-200705-19 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
3982PHP 4.x < 4.4.7 / 5.x < 5.2.2 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
25159PHP < 4.4.7 / 5.2.2 Multiple VulnerabilitiesNessusCGI abuses
high
3857PHP < 4.4.5 / 5.2.1 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
medium
801112PHP < 4.4.5 / 5.2.1 Multiple VulnerabilitiesLog Correlation EngineWeb Servers
high
801085PHP < 4.4.7 / 5.2.2 Multiple VulnerabilitiesLog Correlation EngineWeb Servers
high