Slackware Linux 15.0 / current httpd Multiple Vulnerabilities (SSA:2024-095-01)

high Nessus Plugin ID 192935


The remote Slackware Linux host is missing a security update to httpd.


The version of httpd installed on the remote host is prior to 2.4.59. It is, therefore, affected by multiple vulnerabilities as referenced in the SSA:2024-095-01 advisory.

- Faulty input validation in the core of Apache allows malicious or exploitable backend/content generators to split HTTP responses. This issue affects Apache HTTP Server: through 2.4.58. (CVE-2023-38709)

- HTTP Response splitting in multiple modules in Apache HTTP Server allows an attacker that can inject malicious response headers into backend applications to cause an HTTP desynchronization attack. Users are recommended to upgrade to version 2.4.59, which fixes this issue. (CVE-2024-24795)

- HTTP/2 incoming headers exceeding the limit are temporarily buffered in nghttp2 in order to generate an informative HTTP 413 response. If a client does not stop sending headers, this leads to memory exhaustion.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade the affected httpd package.

See Also

Plugin Details

Severity: High

ID: 192935

File Name: Slackware_SSA_2024-095-01.nasl

Version: 1.1

Type: local

Published: 4/4/2024

Updated: 4/12/2024

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 5.2


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2024-27316


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:httpd, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Patch Publication Date: 4/4/2024

Vulnerability Publication Date: 4/4/2024

Reference Information

CVE: CVE-2023-38709, CVE-2024-24795, CVE-2024-27316

IAVA: 2024-A-0202