Ubuntu 16.04 LTS / 18.04 LTS / 18.10 / 19.04 : ImageMagick vulnerabilities (USN-4034-1)

high Nessus Plugin ID 126254
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Ubuntu host is missing one or more security-related patches.

Description

It was discovered that ImageMagick incorrectly handled certain malformed image files. If a user or automated system using ImageMagick were tricked into opening a specially crafted image, an attacker could exploit this to cause a denial of service or possibly execute code with the privileges of the user invoking the program.

Due to a large number of issues discovered in GhostScript that prevent it from being used by ImageMagick safely, the update for Ubuntu 18.10 and Ubuntu 19.04 includes a default policy change that disables support for the Postscript and PDF formats in ImageMagick. This policy can be overridden if necessary by using an alternate ImageMagick policy configuration.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected packages.

See Also

https://usn.ubuntu.com/4034-1/

Plugin Details

Severity: High

ID: 126254

File Name: ubuntu_USN-4034-1.nasl

Version: 1.5

Type: local

Agent: unix

Published: 6/26/2019

Updated: 9/17/2020

Dependencies: ssh_get_info.nasl

Risk Information

CVSS Score Source: CVE-2019-9956

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.3

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:imagemagick, p-cpe:/a:canonical:ubuntu_linux:imagemagick-6.q16, p-cpe:/a:canonical:ubuntu_linux:libmagick%2b%2b-6.q16-5v5, p-cpe:/a:canonical:ubuntu_linux:libmagick%2b%2b-6.q16-7, p-cpe:/a:canonical:ubuntu_linux:libmagick%2b%2b-6.q16-8, p-cpe:/a:canonical:ubuntu_linux:libmagickcore-6.q16-2, p-cpe:/a:canonical:ubuntu_linux:libmagickcore-6.q16-2-extra, p-cpe:/a:canonical:ubuntu_linux:libmagickcore-6.q16-3, p-cpe:/a:canonical:ubuntu_linux:libmagickcore-6.q16-3-extra, p-cpe:/a:canonical:ubuntu_linux:libmagickcore-6.q16-6, p-cpe:/a:canonical:ubuntu_linux:libmagickcore-6.q16-6-extra, cpe:/o:canonical:ubuntu_linux:16.04, cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:18.10, cpe:/o:canonical:ubuntu_linux:19.04

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/25/2019

Vulnerability Publication Date: 7/20/2018

Reference Information

CVE: CVE-2017-12805, CVE-2017-12806, CVE-2018-14434, CVE-2018-15607, CVE-2018-16323, CVE-2018-16412, CVE-2018-16413, CVE-2018-16644, CVE-2018-16645, CVE-2018-17965, CVE-2018-17966, CVE-2018-18016, CVE-2018-18023, CVE-2018-18024, CVE-2018-18025, CVE-2018-18544, CVE-2018-20467, CVE-2019-10131, CVE-2019-10649, CVE-2019-10650, CVE-2019-11470, CVE-2019-11472, CVE-2019-11597, CVE-2019-11598, CVE-2019-7175, CVE-2019-7395, CVE-2019-7396, CVE-2019-7397, CVE-2019-7398, CVE-2019-9956

USN: 4034-1