CVE-2018-18025

MEDIUM

Description

In ImageMagick 7.0.8-13 Q16, there is a heap-based buffer over-read in the EncodeImage function of coders/pict.c, which allows attackers to cause a denial of service via a crafted SVG image file.

References

https://github.com/ImageMagick/ImageMagick/issues/1335

https://lists.debian.org/debian-lts-announce/2018/11/msg00014.html

https://lists.debian.org/debian-lts-announce/2020/09/msg00007.html

https://usn.ubuntu.com/4034-1/

Details

Source: MITRE

Published: 2018-10-07

Updated: 2020-09-08

Type: CWE-125

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 2.8

Severity: MEDIUM

Tenable Plugins

View all (3 total)

IDNameProductFamilySeverity
140297Debian DLA-2366-1 : imagemagick security updateNessusDebian Local Security Checks
high
126254Ubuntu 16.04 LTS / 18.04 LTS / 18.10 / 19.04 : ImageMagick vulnerabilities (USN-4034-1)NessusUbuntu Local Security Checks
medium
118889Debian DLA-1574-1 : imagemagick security updateNessusDebian Local Security Checks
medium