CVE-2019-11598

MEDIUM

Description

In ImageMagick 7.0.8-40 Q16, there is a heap-based buffer over-read in the function WritePNMImage of coders/pnm.c, which allows an attacker to cause a denial of service or possibly information disclosure via a crafted image file. This is related to SetGrayscaleImage in MagickCore/quantize.c.

References

http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00057.html

http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00001.html

http://www.securityfocus.com/bid/108102

https://github.com/ImageMagick/ImageMagick/issues/1540

https://lists.debian.org/debian-lts-announce/2019/05/msg00015.html

https://lists.debian.org/debian-lts-announce/2020/09/msg00007.html

https://usn.ubuntu.com/4034-1/

https://www.debian.org/security/2020/dsa-4712

Details

Source: MITRE

Published: 2019-04-29

Updated: 2020-09-08

Type: CWE-125

Risk Information

CVSS v2.0

Base Score: 5.8

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:P

Impact Score: 4.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H

Impact Score: 5.2

Exploitability Score: 2.8

Severity: HIGH