openSUSE Security Update : mysql-community-server (openSUSE-2018-405)

high Nessus Plugin ID 109424

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for mysql-community-server to version 5.6.40 fixes the following issues :

Security issues fixed :

- CVE-2018-2755: Unspecified vulnerability in the Replication component

- CVE-2018-2819: Unspecified vulnerability in the InnoDB component

- CVE-2018-2817: Unspecified vulnerability in the Server DDL component

- CVE-2018-2761: Unspecified vulnerability in the client programs

- CVE-2018-2818: Unspecified vulnerability in the Server Security Privileges component

- CVE-2018-2781: Unspecified vulnerability in the Server Optimizer component

- CVE-2018-2771: Unspecified vulnerability in the Server locking component

- CVE-2018-2813: Unspecified vulnerability in the Server DDL component

- CVE-2018-2773: Unspecified vulnerability in the client programs

- CVE-2018-2758: Unspecified vulnerability in the Server Security Privileges component

- CVE-2018-2805: Unspecified vulnerability in the GIS Extension

- CVE-2018-2782: Unspecified vulnerability in the InnoDB component

- CVE-2018-2784: Unspecified vulnerability in the InnoDB component

- CVE-2018-2787: Unspecified vulnerability in the InnoDB component

- CVE-2018-2766: Unspecified vulnerability in the InnoDB component

This update also contains all upstream fixes and improvement in the 5.6.40 release:
http://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-40.html

Solution

Update the affected mysql-community-server packages.

See Also

https://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-40.html

https://bugzilla.opensuse.org/show_bug.cgi?id=1089987

Plugin Details

Severity: High

ID: 109424

File Name: openSUSE-2018-405.nasl

Version: 1.5

Type: local

Agent: unix

Published: 4/30/2018

Updated: 1/19/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.5

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C

CVSS v3

Risk Factor: High

Base Score: 7.7

Vector: CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:o:novell:opensuse:42.3:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:mysql-community-server:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:mysql-community-server-bench:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:mysql-community-server-bench-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:mysql-community-server-client:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:mysql-community-server-client-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:mysql-community-server-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:mysql-community-server-debugsource:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:mysql-community-server-test:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:mysql-community-server-test-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:mysql-community-server-tools:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:mysql-community-server-tools-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libmysql56client18:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libmysql56client18-32bit:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libmysql56client18-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libmysql56client18-debuginfo-32bit:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libmysql56client_r18:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libmysql56client_r18-32bit:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:mysql-community-server-errormessages:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 4/27/2018

Reference Information

CVE: CVE-2018-2755, CVE-2018-2761, CVE-2018-2771, CVE-2018-2773, CVE-2018-2781, CVE-2018-2813, CVE-2018-2817, CVE-2018-2818, CVE-2018-2819, CVE-2018-2766, CVE-2018-2782, CVE-2018-2784, CVE-2018-2787, CVE-2018-2758, CVE-2018-2805