PHP 7.2.x < 7.2.1 Multiple Vulnerabilities

Medium Nessus Plugin ID 105774

Synopsis

The version of PHP running on the remote web server is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP running on the remote web server is 7.2.x prior to 7.2.1. It is, therefore, affected by multiple vulnerabilities.

Solution

Upgrade to PHP version 7.2.1 or later.

See Also

http://php.net/ChangeLog-7.php#7.2.1

Plugin Details

Severity: Medium

ID: 105774

File Name: php_7_2_1.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 2018/01/12

Modified: 2018/08/08

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Patch Publication Date: 2018/01/04

Vulnerability Publication Date: 2018/01/04