CVE-2018-14884

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

An issue was discovered in PHP 7.0.x before 7.0.27, 7.1.x before 7.1.13, and 7.2.x before 7.2.1. Inappropriately parsing an HTTP response leads to a segmentation fault because http_header_value in ext/standard/http_fopen_wrapper.c can be a NULL value that is mishandled in an atoi call.

References

http://php.net/ChangeLog-7.php

https://access.redhat.com/errata/RHSA-2019:2519

https://bugs.php.net/bug.php?id=75535

https://security.netapp.com/advisory/ntap-20181107-0003/

Details

Source: MITRE

Published: 2018-08-03

Updated: 2019-08-19

Type: CWE-476

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (6 total)

IDNameProductFamilySeverity
98865PHP 7.2.x < 7.2.1 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98858PHP 7.1.x < 7.1.13 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98846PHP 7.0.x < 7.0.27 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
105774PHP 7.2.x < 7.2.1 Multiple VulnerabilitiesNessusCGI abuses
medium
105773PHP 7.1.x < 7.1.13 Multiple VulnerabilitiesNessusCGI abuses
medium
105772PHP 7.0.x < 7.0.27 Multiple VulnerabilitiesNessusCGI abuses
medium