CVE-2018-5712

MEDIUM
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

An issue was discovered in PHP before 5.6.33, 7.0.x before 7.0.27, 7.1.x before 7.1.13, and 7.2.x before 7.2.1. There is Reflected XSS on the PHAR 404 error page via the URI of a request for a .phar file.

References

http://php.net/ChangeLog-5.php

http://php.net/ChangeLog-7.php

http://www.securityfocus.com/bid/102742

http://www.securityfocus.com/bid/104020

http://www.securitytracker.com/id/1040363

https://access.redhat.com/errata/RHSA-2018:1296

https://access.redhat.com/errata/RHSA-2019:2519

https://bugs.php.net/bug.php?id=74782

https://lists.debian.org/debian-lts-announce/2018/01/msg00025.html

https://usn.ubuntu.com/3566-1/

https://usn.ubuntu.com/3600-1/

https://usn.ubuntu.com/3600-2/

Details

Source: MITRE

Published: 2018-01-16

Updated: 2019-08-19

Type: CWE-79

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Impact Score: 2.7

Exploitability Score: 2.8

Severity: MEDIUM

Tenable Plugins

View all (30 total)

IDNameProductFamilySeverity
143988NewStart CGSL CORE 5.05 / MAIN 5.05 : php Multiple Vulnerabilities (NS-SA-2020-0090)NessusNewStart CGSL Local Security Checks
critical
143917NewStart CGSL CORE 5.04 / MAIN 5.04 : php Multiple Vulnerabilities (NS-SA-2020-0059)NessusNewStart CGSL Local Security Checks
critical
137966EulerOS Virtualization 3.0.6.0 : php (EulerOS-SA-2020-1747)NessusHuawei Local Security Checks
critical
135827Scientific Linux Security Update : php on SL7.x x86_64 (20200407)NessusScientific Linux Local Security Checks
critical
135338CentOS 7 : php (CESA-2020:1112)NessusCentOS Local Security Checks
critical
135040RHEL 7 : php (RHSA-2020:1112)NessusRed Hat Local Security Checks
critical
132184EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2649)NessusHuawei Local Security Checks
critical
131592EulerOS 2.0 SP2 : php (EulerOS-SA-2019-2438)NessusHuawei Local Security Checks
critical
129178EulerOS 2.0 SP5 : php (EulerOS-SA-2019-1984)NessusHuawei Local Security Checks
critical
98824PHP 5.6.x < 5.6.33 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
98865PHP 7.2.x < 7.2.1 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98858PHP 7.1.x < 7.1.13 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98846PHP 7.0.x < 7.0.27 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
120886Fedora 28 : php (2018-ee6707d519)NessusFedora Local Security Checks
high
120015SUSE SLES12 Security Update : php7 (SUSE-SU-2018:0308-1)NessusSuSE Local Security Checks
medium
120013SUSE SLES12 Security Update : php5 (SUSE-SU-2018:0216-1)NessusSuSE Local Security Checks
medium
109560Fedora 26 : php (2018-6071a600e8)NessusFedora Local Security Checks
high
109559Fedora 27 : php (2018-04f6056c42)NessusFedora Local Security Checks
high
108650SUSE SLES11 Security Update : php53 (SUSE-SU-2018:0806-1)NessusSuSE Local Security Checks
critical
108483Ubuntu 14.04 LTS / 16.04 LTS / 17.10 : PHP vulnerabilities (USN-3600-1)NessusUbuntu Local Security Checks
critical
106792Ubuntu 14.04 LTS : php5 vulnerabilities (USN-3566-1)NessusUbuntu Local Security Checks
critical
106691Amazon Linux AMI : php56 / php70,php71 (ALAS-2018-946)NessusAmazon Linux Local Security Checks
medium
106586Slackware 14.0 / 14.1 / 14.2 / current : php (SSA:2018-034-01)NessusSlackware Local Security Checks
medium
106550openSUSE Security Update : php7 (openSUSE-2018-119)NessusSuSE Local Security Checks
medium
106434openSUSE Security Update : php5 (openSUSE-2018-99)NessusSuSE Local Security Checks
medium
106207Debian DLA-1251-1 : php5 security updateNessusDebian Local Security Checks
medium
105774PHP 7.2.x < 7.2.1 Multiple VulnerabilitiesNessusCGI abuses
medium
105773PHP 7.1.x < 7.1.13 Multiple VulnerabilitiesNessusCGI abuses
medium
105772PHP 7.0.x < 7.0.27 Multiple VulnerabilitiesNessusCGI abuses
medium
105771PHP 5.6.x < 5.6.33 Multiple VulnerabilitiesNessusCGI abuses
medium