CVE-2018-5711

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

gd_gif_in.c in the GD Graphics Library (aka libgd), as used in PHP before 5.6.33, 7.0.x before 7.0.27, 7.1.x before 7.1.13, and 7.2.x before 7.2.1, has an integer signedness error that leads to an infinite loop via a crafted GIF file, as demonstrated by a call to the imagecreatefromgif or imagecreatefromstring PHP function. This is related to GetCode_ and gdImageCreateFromGifCtx.

References

http://php.net/ChangeLog-5.php

http://php.net/ChangeLog-7.php

https://access.redhat.com/errata/RHSA-2018:1296

https://access.redhat.com/errata/RHSA-2019:2519

https://bugs.php.net/bug.php?id=75571

https://lists.debian.org/debian-lts-announce/2018/01/msg00022.html

https://lists.debian.org/debian-lts-announce/2019/01/msg00028.html

https://security.gentoo.org/glsa/201903-18

https://usn.ubuntu.com/3755-1/

Details

Source: MITRE

Published: 2018-01-16

Updated: 2019-10-03

Type: CWE-681

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM

Tenable Plugins

View all (30 total)

IDNameProductFamilySeverity
137966EulerOS Virtualization 3.0.6.0 : php (EulerOS-SA-2020-1747)NessusHuawei Local Security Checks
critical
134850Slackware 14.2 / current : gd (SSA:2020-083-01)NessusSlackware Local Security Checks
critical
132184EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2649)NessusHuawei Local Security Checks
critical
131674EulerOS 2.0 SP2 : gd (EulerOS-SA-2019-2521)NessusHuawei Local Security Checks
critical
129178EulerOS 2.0 SP5 : php (EulerOS-SA-2019-1984)NessusHuawei Local Security Checks
critical
98824PHP 5.6.x < 5.6.33 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
123424GLSA-201903-18 : GD: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
121483Debian DLA-1651-1 : libgd2 security updateNessusDebian Local Security Checks
critical
98865PHP 7.2.x < 7.2.1 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98858PHP 7.1.x < 7.1.13 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98846PHP 7.0.x < 7.0.27 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
120264Fedora 28 : gd (2018-1aeac808ce)NessusFedora Local Security Checks
medium
120015SUSE SLES12 Security Update : php7 (SUSE-SU-2018:0308-1)NessusSuSE Local Security Checks
medium
120013SUSE SLES12 Security Update : php5 (SUSE-SU-2018:0216-1)NessusSuSE Local Security Checks
medium
112150Ubuntu 14.04 LTS / 16.04 LTS / 18.04 LTS : GD vulnerabilities (USN-3755-1)NessusUbuntu Local Security Checks
high
108836Fedora 26 : gd (2018-331af74020)NessusFedora Local Security Checks
medium
108700Fedora 27 : gd (2018-ba81e4e4a0)NessusFedora Local Security Checks
medium
108650SUSE SLES11 Security Update : php53 (SUSE-SU-2018:0806-1)NessusSuSE Local Security Checks
critical
106691Amazon Linux AMI : php56 / php70,php71 (ALAS-2018-946)NessusAmazon Linux Local Security Checks
medium
106586Slackware 14.0 / 14.1 / 14.2 / current : php (SSA:2018-034-01)NessusSlackware Local Security Checks
medium
106550openSUSE Security Update : php7 (openSUSE-2018-119)NessusSuSE Local Security Checks
medium
106543openSUSE Security Update : gd (openSUSE-2018-109)NessusSuSE Local Security Checks
medium
106470SUSE SLED12 / SLES12 Security Update : gd (SUSE-SU-2018:0260-1)NessusSuSE Local Security Checks
medium
106439SUSE SLES11 Security Update : gd (SUSE-SU-2018:0235-1)NessusSuSE Local Security Checks
medium
106434openSUSE Security Update : php5 (openSUSE-2018-99)NessusSuSE Local Security Checks
medium
106175Debian DLA-1248-1 : libgd2 security updateNessusDebian Local Security Checks
medium
105774PHP 7.2.x < 7.2.1 Multiple VulnerabilitiesNessusCGI abuses
medium
105773PHP 7.1.x < 7.1.13 Multiple VulnerabilitiesNessusCGI abuses
medium
105772PHP 7.0.x < 7.0.27 Multiple VulnerabilitiesNessusCGI abuses
medium
105771PHP 5.6.x < 5.6.33 Multiple VulnerabilitiesNessusCGI abuses
medium