Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

PostgreSQL 9.1 < 9.1.20 / 9.2 < 9.2.15 / 9.3 < 9.3.11 / 9.4 < 9.4.6 / 9.5 < 9.5.1 Multiple Vulnerabilities



The database running on the remote server is affected by multiple vulnerabilities.


The version of PostgreSQL installed on the remote host is 9.1.x prior to 9.1.20, 9.2.x prior to 9.2.15, 9.3.x prior to 9.3.11, or 9.4.x prior to 9.4.6, or 9.5.x prior to 9.5.1 and is affected by multiple vulnerabilities :

- An integer overflow condition exists that is triggered as user-supplied input is not properly validated when handling regular expressions. This may allow an attacker to cause a heap-based buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code. (OSVDB 134458) - A flaw exists in the 'init_custom_variable()' function in 'backend/utils/misc/guc.c' that is triggered during the handling of PL/Java. This may allow an attacker to gain elevated privileges. (OSVDB 134459) - A flaw exists related to certain security definer functions or when a common user and query is planned initially and reused across multiple SET ROLEs. This may allow an authenticated attacker to cause incorrect policies to be applied in cases where role-specific polices are used. (OSVDB 136561) - A flaw exists in 'contrib/pageinspect/brinfuncs.c' that is triggered during the use of pageinspect functions on BRIN index pages. This may allow an authenticated attacker to cause a crash or gain access to a small amount of server memory information, which may potentially contain credential information. (OSVDB 136562)


Upgrade to PostgreSQL 9.1.20 / 9.2.15 / 9.3.11 / 9.4.6 / 9.5.1, or later.