CVE-2016-0766

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

PostgreSQL before 9.1.20, 9.2.x before 9.2.15, 9.3.x before 9.3.11, 9.4.x before 9.4.6, and 9.5.x before 9.5.1 does not properly restrict access to unspecified custom configuration settings (GUCS) for PL/Java, which allows attackers to gain privileges via unspecified vectors.

References

http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00049.html

http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00052.html

http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00054.html

http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00056.html

http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00016.html

http://www.debian.org/security/2016/dsa-3475

http://www.debian.org/security/2016/dsa-3476

http://www.postgresql.org/about/news/1644/

http://www.postgresql.org/docs/current/static/release-9-1-20.html

http://www.postgresql.org/docs/current/static/release-9-2-15.html

http://www.postgresql.org/docs/current/static/release-9-3-11.html

http://www.postgresql.org/docs/current/static/release-9-4-6.html

http://www.postgresql.org/docs/current/static/release-9-5-1.html

http://www.securityfocus.com/bid/83184

http://www.securitytracker.com/id/1035005

http://www.ubuntu.com/usn/USN-2894-1

https://security.gentoo.org/glsa/201701-33

Details

Source: MITRE

Published: 2016-02-17

Updated: 2017-07-01

Type: CWE-264

Risk Information

CVSS v2

Base Score: 9

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8

Severity: HIGH

CVSS v3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:* versions up to 9.1.19 (inclusive)

cpe:2.3:a:postgresql:postgresql:9.2:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.1:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.2:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.3:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.4:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.5:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.6:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.7:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.8:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.9:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.10:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.11:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.12:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.13:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.14:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.4:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.4.1:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.4.2:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.4.3:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.4.4:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.4.5:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.5:*:*:*:*:*:*:*

Configuration 2

OR

cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:*

cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:*

cpe:2.3:o:canonical:ubuntu_linux:15.10:*:*:*:*:*:*:*

cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*

cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*

Tenable Plugins

View all (12 total)

IDNameProductFamilySeverity
96474GLSA-201701-33 : PostgreSQL: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
9264PostgreSQL 9.1 < 9.1.20 / 9.2 < 9.2.15 / 9.3 < 9.3.11 / 9.4 < 9.4.6 / 9.5 < 9.5.1 Multiple VulnerabilitiesNessus Network MonitorDatabase
high
89730SUSE SLED11 / SLES11 Security Update : postgresql94 (SUSE-SU-2016:0677-1)NessusSuSE Local Security Checks
high
88980openSUSE Security Update : postgresql94 (openSUSE-2016-271)NessusSuSE Local Security Checks
high
88948SUSE SLED12 / SLES12 Security Update : postgresql94 (SUSE-SU-2016:0555-1)NessusSuSE Local Security Checks
high
88926openSUSE Security Update : postgresql93 (openSUSE-2016-253)NessusSuSE Local Security Checks
high
88891SUSE SLED12 / SLES12 Security Update : postgresql93 (SUSE-SU-2016:0539-1)NessusSuSE Local Security Checks
high
88808PostgreSQL 9.1.x < 9.1.20 / 9.2.x < 9.2.15 / 9.3.x < 9.3.11 / 9.4.x < 9.4.6 / 9.5.x < 9.5.1 Multiple VulnerabilitiesNessusDatabases
high
88731FreeBSD : PostgreSQL -- Security Fixes for Regular Expressions, PL/Java. (e8b6605b-d29f-11e5-8458-6cc21735f730)NessusFreeBSD Local Security Checks
high
88727Debian DSA-3476-1 : postgresql-9.4 - security updateNessusDebian Local Security Checks
high
88726Debian DSA-3475-1 : postgresql-9.1 - security updateNessusDebian Local Security Checks
high
88712Ubuntu 12.04 LTS / 14.04 LTS / 15.10 : postgresql-9.1, postgresql-9.3, postgresql-9.4 vulnerabilities (USN-2894-1)NessusUbuntu Local Security Checks
high