CVE-2016-3065

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The (1) brin_page_type and (2) brin_metapage_info functions in the pageinspect extension in PostgreSQL before 9.5.x before 9.5.2 allows attackers to bypass intended access restrictions and consequently obtain sensitive server memory information or cause a denial of service (server crash) via a crafted bytea value in a BRIN index page.

References

http://git.postgresql.org/gitweb/?p=postgresql.git;a=commitdiff;h=bf78a6f107949fdfb513d1b45e30cefe04e09e4f

http://www.postgresql.org/about/news/1656/

http://www.postgresql.org/docs/current/static/release-9-5-2.html

http://www.securitytracker.com/id/1035468

Details

Source: MITRE

Published: 2016-04-11

Updated: 2016-04-14

Type: CWE-264

Risk Information

CVSS v2

Base Score: 8.5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:C

Impact Score: 7.8

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Impact Score: 5.2

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (3 total)

IDNameProductFamilySeverity
9264PostgreSQL 9.1 < 9.1.20 / 9.2 < 9.2.15 / 9.3 < 9.3.11 / 9.4 < 9.4.6 / 9.5 < 9.5.1 Multiple VulnerabilitiesNessus Network MonitorDatabase
high
90423PostgreSQL 9.5.x < 9.5.2 Multiple VulnerabilitiesNessusDatabases
critical
90290FreeBSD : PostgreSQL -- minor security problems. (97a24d2e-f74c-11e5-8458-6cc21735f730)NessusFreeBSD Local Security Checks
critical