PHP 7.2.x < 7.2.29 Multiple Vulnerabilities

high Web App Scanning Plugin ID 98993


PHP 7.2.x < 7.2.29 Multiple Vulnerabilities


According to its banner, the version of PHP running on the remote web server is prior to 7.2.29, 7.3.x prior to 7.3.16, or 7.4.x prior to 7.4.4. It is, therefore, affected by multiple vulnerabilities: - An improper null termination exists in get_headers due to a silent truncation after a null byte. (CVE-2020-7066) - An out-of-bounds read error exists in exif due to the use of uninitialized value. (CVE-2020-7064) - A stack-based buffer overflow condition exists in php_unicode_tolower_full due to a call to mb_strtolower. (CVE-2020-7065) Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to PHP version 7.2.29 or later.

See Also

Plugin Details

Severity: High

ID: 98993

Type: remote

Published: 3/24/2020

Updated: 3/14/2023

Scan Template: api, basic, full, pci, scan

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: Medium

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2020-7065


Risk Factor: High

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVSS Score Source: CVE-2020-7065

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/1/2020

Vulnerability Publication Date: 4/1/2020

Reference Information

CVE: CVE-2020-7064, CVE-2020-7065, CVE-2020-7066