CVE-2020-7065

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In PHP versions 7.3.x below 7.3.16 and 7.4.x below 7.4.4, while using mb_strtolower() function with UTF-32LE encoding, certain invalid strings could cause PHP to overwrite stack-allocated buffer. This could lead to memory corruption, crashes and potentially code execution.

References

https://bugs.php.net/bug.php?id=79371

https://security.netapp.com/advisory/ntap-20200403-0001/

https://usn.ubuntu.com/4330-1/

https://usn.ubuntu.com/4330-2/

https://www.debian.org/security/2020/dsa-4719

https://www.php.net/ChangeLog-7.php#7.4.4

https://www.tenable.com/security/tns-2021-14

https://www.oracle.com/security-alerts/cpuoct2021.html

Details

Source: MITRE

Published: 2020-04-01

Updated: 2021-12-02

Type: CWE-787

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.8

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Tenable Plugins

View all (16 total)

IDNameProductFamilySeverity
152986Tenable SecurityCenter < 5.19.0 Multiple Vulnerabilities (TNS-2021-14)NessusMisc.
high
151985Tenable.sc < 5.19.0 Multiple Vulnerabilities (TNS-2021-14) (deprecated)NessusMisc.
high
145957CentOS 8 : php:7.3 (CESA-2020:3662)NessusCentOS Local Security Checks
critical
140482Oracle Linux 8 : php:7.3 (ELSA-2020-3662)NessusOracle Linux Local Security Checks
critical
140396RHEL 8 : php:7.3 (RHSA-2020:3662)NessusRed Hat Local Security Checks
critical
138225Debian DSA-4719-1 : php7.3 - security updateNessusDebian Local Security Checks
high
136629Amazon Linux AMI : php73 (ALAS-2020-1368)NessusAmazon Linux Local Security Checks
high
136398Ubuntu 20.04 : php7.4 vulnerabilities (USN-4330-2)NessusUbuntu Local Security Checks
high
135672Ubuntu 16.04 LTS / 18.04 LTS / 19.10 : PHP vulnerabilities (USN-4330-1)NessusUbuntu Local Security Checks
high
134965GLSA-202003-57 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
134962Fedora 30 : php (2020-ce5a2a7403)NessusFedora Local Security Checks
high
134944PHP 7.3.x < 7.3.16 Multiple VulnerabilitiesNessusCGI abuses
high
134919Fedora 31 : php (2020-0bf228857a)NessusFedora Local Security Checks
high
98993PHP 7.2.x < 7.2.29 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98992PHP 7.3.x < 7.3.16 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98991PHP 7.4.x < 7.4.4 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high