PHP 7.3.x < 7.3.0 Multiple vulnerabilities

High Web Application Scanning Plugin ID 98884


PHP 7.3.x < 7.3.0 Multiple vulnerabilities


According to its banner, the version of PHP running on the remote web server is 5.6.x prior to 5.6.39, 7.0.x prior to 7.0.33, 7.1.x prior to 7.1.25, 7.2.x prior to 7.2.13 or 7.3.x prior to 7.3.0. It is, therefore, affected by multiple vulnerabilities:

- An arbitrary command injection vulnerability exists in the imap_open function due to improper filters for mailbox names prior to passing them to rsh or ssh commands. An authenticated, remote attacker can exploit this by sending a specially crafted IMAP server name to cause the execution of arbitrary commands on the target system. (CVE-2018-19518)

- A heap buffer over-read exists in the phar_parse_pharfile function. An unauthenticated, remote attacker can exploit this to read allocated or unallocated memory past the actual data when trying to parse a .phar file. (CVE-2018-20783)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to PHP version 7.3.0 or later.

See Also

Plugin Details

Severity: High

ID: 98884

Type: remote

Published: 2019/01/31

Updated: 2020/02/19

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 8.5

Vector: CVSS2#AV:N/AC:M/Au:S/C:C/I:C/A:C

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Available: true

Patch Publication Date: 2018/12/06

Vulnerability Publication Date: 2018/12/06

Reference Information

CVE: CVE-2018-19518, CVE-2018-20783

BID: 106018, 107121

CWE: 77

WASC: OS Commanding

OWASP: 2010-A1, 2013-A1, 2013-A9, 2017-A1, 2017-A9