CVE-2018-20783

HIGH
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In PHP before 5.6.39, 7.x before 7.0.33, 7.1.x before 7.1.25, and 7.2.x before 7.2.13, a buffer over-read in PHAR reading functions may allow an attacker to read allocated or unallocated memory past the actual data when trying to parse a .phar file. This is related to phar_parse_pharfile in ext/phar/phar.c.

References

http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00083.html

http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00104.html

http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html

http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html

http://php.net/ChangeLog-5.php

http://php.net/ChangeLog-7.php

https://access.redhat.com/errata/RHSA-2019:2519

https://access.redhat.com/errata/RHSA-2019:3299

https://bugs.php.net/bug.php?id=77143

https://usn.ubuntu.com/3566-2/

Details

Source: MITRE

Published: 2019-02-21

Updated: 2019-05-22

Type: CWE-125

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (26 total)

IDNameProductFamilySeverity
145814CentOS 8 : php:7.2 (CESA-2020:1624)NessusCentOS Local Security Checks
critical
136057RHEL 8 : php:7.2 (RHSA-2020:1624)NessusRed Hat Local Security Checks
critical
126035openSUSE Security Update : php7 (openSUSE-2019-1573)NessusSuSE Local Security Checks
critical
126034openSUSE Security Update : php7 (openSUSE-2019-1572)NessusSuSE Local Security Checks
critical
125850SUSE SLED15 / SLES15 Security Update : php7 (SUSE-SU-2019:1461-1)NessusSuSE Local Security Checks
critical
125352Ubuntu 14.04 LTS : PHP vulnerabilities (USN-3566-2)NessusUbuntu Local Security Checks
critical
124998EulerOS Virtualization 3.0.1.0 : php (EulerOS-SA-2019-1545)NessusHuawei Local Security Checks
critical
124905EulerOS Virtualization for ARM 64 3.0.1.0 : php (EulerOS-SA-2019-1402)NessusHuawei Local Security Checks
critical
124401openSUSE Security Update : php7 (openSUSE-2019-1293)NessusSuSE Local Security Checks
critical
124263openSUSE Security Update : php5 (openSUSE-2019-1256)NessusSuSE Local Security Checks
critical
124190SUSE SLES12 Security Update : php5 (SUSE-SU-2019:0985-1)NessusSuSE Local Security Checks
critical
123826SUSE SLES11 Security Update : php53 (SUSE-SU-2019:14013-1)NessusSuSE Local Security Checks
critical
123742EulerOS Virtualization 2.5.3 : php (EulerOS-SA-2019-1274)NessusHuawei Local Security Checks
high
123620EulerOS 2.0 SP5 : php (EulerOS-SA-2019-1146)NessusHuawei Local Security Checks
critical
123594EulerOS 2.0 SP2 : php (EulerOS-SA-2019-1120)NessusHuawei Local Security Checks
critical
123113EulerOS 2.0 SP3 : php (EulerOS-SA-2019-1100)NessusHuawei Local Security Checks
critical
122821PHP 7.0.x < 7.0.33 Multiple vulnerabilitiesNessusCGI abuses
high
98884PHP 7.3.x < 7.3.0 Multiple vulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98883PHP 7.2.x < 7.2.13 Multiple vulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98882PHP 7.1.x < 7.1.25 Multiple vulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98881PHP 7.0.x < 7.0.33 Multiple vulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98880PHP 5.6.x < 5.6.39 Multiple vulnerabilitiesWeb Application ScanningComponent Vulnerability
high
119766PHP 7.2.x < 7.2.13 Multiple vulnerabilitiesNessusCGI abuses
high
119765PHP 7.1.x < 7.1.25 Multiple vulnerabilitiesNessusCGI abuses
high
119764PHP 5.6.x < 5.6.39 Multiple vulnerabilitiesNessusCGI abuses
high
111217PHP 7.3.0 [alpha|beta] < 7.3.0 Multiple vulnerabilitiesNessusCGI abuses
high