PHP 7.1.x < 7.1.9 Heap User After Free Vulnerability

high Web Application Scanning Plugin ID 98877

Synopsis

PHP 7.1.x < 7.1.9 Heap User After Free Vulnerability

Description

According to its banner, the version of PHP running on the remote web server is 7.0.x prior to 7.0.23 or 7.1.x prior to 7.1.9, therefore, affected by a heap user after free vulnerability when unserializing invalid array size.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.1.9 or later.

See Also

http://php.net/ChangeLog-7.php#7.1.9

Plugin Details

Severity: High

ID: 98877

Type: remote

Published: 1/31/2019

Updated: 3/5/2021

Scan Template: api, scan, pci

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Patch Publication Date: 8/18/2017

Vulnerability Publication Date: 8/18/2017

Reference Information

CVE: CVE-2017-12932

CWE: 416

OWASP: 2013-A9, 2017-A9

OWASP API: 2019-API7