PHP 7.1.x < 7.1.9 Heap User After Free Vulnerability

High Web Application Scanning Plugin ID 98877


PHP 7.1.x < 7.1.9 Heap User After Free Vulnerability


According to its banner, the version of PHP running on the remote web server is 7.0.x prior to 7.0.23 or 7.1.x prior to 7.1.9, therefore, affected by a heap user after free vulnerability when unserializing invalid array size.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to PHP version 7.1.9 or later.

See Also

Plugin Details

Severity: High

ID: 98877

Type: remote

Published: 2019/01/31

Updated: 2020/02/19

Scan Template: api, scan, pci

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2017/08/31

Vulnerability Publication Date: 2017/08/31

Reference Information

CVE: CVE-2017-12932

BID: 100427

CWE: 416

OWASP: 2013-A9, 2017-A9