CVE-2017-12932

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

ext/standard/var_unserializer.re in PHP 7.0.x through 7.0.22 and 7.1.x through 7.1.8 is prone to a heap use after free while unserializing untrusted data, related to improper use of the hash API for key deletion in a situation with an invalid array size. Exploitation of this issue can have an unspecified impact on the integrity of PHP.

References

http://php.net/ChangeLog-7.php

http://www.securityfocus.com/bid/100427

https://access.redhat.com/errata/RHSA-2018:1296

https://access.redhat.com/errata/RHSA-2019:2519

https://bugs.php.net/bug.php?id=74103

https://github.com/php/php-src/commit/1a23ebc1fff59bf480ca92963b36eba5c1b904c4

https://security.gentoo.org/glsa/201709-21

https://security.netapp.com/advisory/ntap-20180112-0001/

https://www.debian.org/security/2018/dsa-4080

Details

Source: MITRE

Published: 2017-08-18

Updated: 2018-05-04

Type: CWE-416

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (9 total)

IDNameProductFamilySeverity
122544PHP 7.2.x < 7.2.0 Heap-based Buffer Overflow VulnerabilityNessusCGI abuses
critical
122543PHP 7.1.x < 7.1.9 Heap-based Buffer Overflow VulnerabilityNessusCGI abuses
critical
122539PHP 7.0.x < 7.0.23 Heap-based Buffer Overflow VulnerabilityNessusCGI abuses
critical
98877PHP 7.1.x < 7.1.9 Heap User After Free VulnerabilityWeb Application ScanningComponent Vulnerability
critical
98876PHP 7.0.x < 7.0.23 Heap User After Free VulnerabilityWeb Application ScanningComponent Vulnerability
critical
120006SUSE SLES12 Security Update : php7 (SUSE-SU-2017:2468-1)NessusSuSE Local Security Checks
critical
105663Debian DSA-4080-1 : php7.0 - security updateNessusDebian Local Security Checks
critical
103449GLSA-201709-21 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
103286openSUSE Security Update : php7 (openSUSE-2017-1061)NessusSuSE Local Security Checks
critical