PHP 5.6.x < 5.6.38 Transfer-Encoding Parameter XSS Vulnerability

Medium Web Application Scanning Plugin ID 98869


PHP 5.6.x < 5.6.38 Transfer-Encoding Parameter XSS Vulnerability


According to its banner, the version of PHP running on the remote web server is 5.6.x prior to 5.6.38, 7.0.x prior to 7.0.32, 7.1.x prior to 7.1.22 or 7.2.x prior to 7.2.10. It is, therefore, affected by a cross-site scripting vulnerability. An attacker could leverage this vulnerability to inject
malicious code which executes within the security context of the affected site.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to PHP version 5.6.38 or later.

See Also

Plugin Details

Severity: Medium

ID: 98869

Type: remote

Published: 2019/01/09

Updated: 2019/01/09

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Available: true

Patch Publication Date: 2018/09/13

Vulnerability Publication Date: 2018/09/13

Reference Information

CVE: CVE-2018-17082