PHP 5.6.x < 5.6.38 Transfer-Encoding Parameter XSS Vulnerability

medium Web Application Scanning Plugin ID 98869
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

PHP 5.6.x < 5.6.38 Transfer-Encoding Parameter XSS Vulnerability

Description

According to its banner, the version of PHP running on the remote web server is 5.6.x prior to 5.6.38, 7.0.x prior to 7.0.32, 7.1.x prior to 7.1.22 or 7.2.x prior to 7.2.10. It is, therefore, affected by a cross-site scripting vulnerability. An attacker could leverage this vulnerability to inject malicious code which executes within the security context of the affected site.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 5.6.38 or later.

See Also

http://php.net/ChangeLog-5.php#5.6.38

Plugin Details

Severity: Medium

ID: 98869

Type: remote

Published: 1/9/2019

Updated: 9/7/2021

Scan Template: api, scan, pci

Risk Information

CVSS Score Source: CVE-2018-17082

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/16/2018

Vulnerability Publication Date: 9/16/2018

Reference Information

CVE: CVE-2018-17082

CWE: 79

WASC: Cross-Site Scripting

OWASP: 2010-A2, 2013-A3, 2013-A9, 2017-A7, 2017-A9, 2021-A3, 2021-A6

OWASP API: 2019-API7