CVE-2018-17082

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The Apache2 component in PHP before 5.6.38, 7.0.x before 7.0.32, 7.1.x before 7.1.22, and 7.2.x before 7.2.10 allows XSS via the body of a "Transfer-Encoding: chunked" request, because the bucket brigade is mishandled in the php_handler function in sapi/apache2handler/sapi_apache2.c.

References

http://php.net/ChangeLog-5.php

http://php.net/ChangeLog-7.php

https://access.redhat.com/errata/RHSA-2019:2519

https://bugs.php.net/bug.php?id=76582

https://github.com/php/php-src/commit/23b057742e3cf199612fa8050ae86cae675e214e

https://lists.debian.org/debian-lts-announce/2018/09/msg00020.html

https://security.gentoo.org/glsa/201812-01

https://security.netapp.com/advisory/ntap-20180924-0001/

https://www.debian.org/security/2018/dsa-4353

https://www.tenable.com/security/tns-2019-07

Details

Source: MITRE

Published: 2018-09-16

Updated: 2019-08-19

Type: CWE-79

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Impact Score: 2.7

Exploitability Score: 2.8

Severity: MEDIUM

Tenable Plugins

View all (27 total)

IDNameProductFamilySeverity
137966EulerOS Virtualization 3.0.6.0 : php (EulerOS-SA-2020-1747)NessusHuawei Local Security Checks
critical
132184EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2649)NessusHuawei Local Security Checks
critical
131592EulerOS 2.0 SP2 : php (EulerOS-SA-2019-2438)NessusHuawei Local Security Checks
critical
129178EulerOS 2.0 SP5 : php (EulerOS-SA-2019-1984)NessusHuawei Local Security Checks
critical
123331openSUSE Security Update : php7 (openSUSE-2019-771)NessusSuSE Local Security Checks
medium
98872PHP 7.2.x < 7.2.10 Transfer-Encoding Parameter XSS VulnerabilityWeb Application ScanningComponent Vulnerability
medium
98871PHP 7.1.x < 7.1.22 Transfer-Encoding Parameter XSS VulnerabilityWeb Application ScanningComponent Vulnerability
medium
98870PHP 7.0.x < 7.0.32 Transfer-Encoding Parameter XSS VulnerabilityWeb Application ScanningComponent Vulnerability
medium
98869PHP 5.6.x < 5.6.38 Transfer-Encoding Parameter XSS VulnerabilityWeb Application ScanningComponent Vulnerability
medium
120726Fedora 28 : php (2018-b6072889db)NessusFedora Local Security Checks
medium
120547Fedora 29 : php (2018-791c3cfe21)NessusFedora Local Security Checks
medium
120121SUSE SLES12 Security Update : php5 (SUSE-SU-2018:3017-1)NessusSuSE Local Security Checks
medium
120120SUSE SLES15 Security Update : php7 (SUSE-SU-2018:3016-1)NessusSuSE Local Security Checks
medium
120107SUSE SLES12 Security Update : php7 (SUSE-SU-2018:2887-1)NessusSuSE Local Security Checks
medium
119561Debian DSA-4353-1 : php7.0 - security updateNessusDebian Local Security Checks
high
119320GLSA-201812-01 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
118210Amazon Linux AMI : php56 / php70,php71,php72 (ALAS-2018-1090)NessusAmazon Linux Local Security Checks
medium
117989SUSE SLES11 Security Update : php53 (SUSE-SU-2018:3018-1)NessusSuSE Local Security Checks
medium
117985openSUSE Security Update : php7 (openSUSE-2018-1131)NessusSuSE Local Security Checks
medium
117984openSUSE Security Update : php5 (openSUSE-2018-1130)NessusSuSE Local Security Checks
medium
117853openSUSE Security Update : php7 (openSUSE-2018-1078)NessusSuSE Local Security Checks
medium
117646Fedora 27 : php (2018-25100b492c)NessusFedora Local Security Checks
medium
117610Debian DLA-1509-1 : php5 security updateNessusDebian Local Security Checks
medium
117500PHP 7.2.x < 7.2.10 Transfer-Encoding Parameter XSS VulnerabilityNessusCGI abuses
medium
117499PHP 7.1.x < 7.1.22 Transfer-Encoding Parameter XSS VulnerabilityNessusCGI abuses
medium
117498PHP 7.0.x < 7.0.32 Transfer-Encoding Parameter XSS VulnerabilityNessusCGI abuses
medium
117497PHP 5.6.x < 5.6.38 Transfer-Encoding Parameter XSS VulnerabilityNessusCGI abuses
medium