PHP 7.2.x < 7.2.5 Multiple Vulnerabilities

medium Web Application Scanning Plugin ID 98868

Synopsis

PHP 7.2.x < 7.2.5 Multiple Vulnerabilities

Description

According to its banner, the version of PHP running on the remote web server is 7.2.x prior to 7.2.5. It is, therefore, affected by multiple vulnerabilities.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.2.5 or later.

See Also

http://php.net/ChangeLog-7.php#7.2.5

Plugin Details

Severity: Medium

ID: 98868

Type: remote

Published: 1/9/2019

Updated: 3/5/2021

Scan Template: api, scan, pci

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Patch Publication Date: 4/29/2018

Vulnerability Publication Date: 4/29/2018

Reference Information

CVE: CVE-2018-10546, CVE-2018-10547, CVE-2018-10548, CVE-2018-10549