CVE-2018-10548

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

An issue was discovered in PHP before 5.6.36, 7.0.x before 7.0.30, 7.1.x before 7.1.17, and 7.2.x before 7.2.5. ext/ldap/ldap.c allows remote LDAP servers to cause a denial of service (NULL pointer dereference and application crash) because of mishandling of the ldap_get_dn return value.

References

http://php.net/ChangeLog-5.php

http://php.net/ChangeLog-7.php

http://www.securityfocus.com/bid/104019

http://www.securitytracker.com/id/1040807

https://access.redhat.com/errata/RHSA-2019:2519

https://bugs.php.net/bug.php?id=76248

https://lists.debian.org/debian-lts-announce/2018/05/msg00004.html

https://lists.debian.org/debian-lts-announce/2018/06/msg00005.html

https://security.gentoo.org/glsa/201812-01

https://security.netapp.com/advisory/ntap-20180607-0003/

https://usn.ubuntu.com/3646-1/

https://usn.ubuntu.com/3646-2/

https://www.debian.org/security/2018/dsa-4240

https://www.tenable.com/security/tns-2018-12

https://www.tenable.com/security/tns-2019-07

Details

Source: MITRE

Published: 2018-04-29

Updated: 2019-08-19

Type: CWE-476

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (28 total)

IDNameProductFamilySeverity
124997EulerOS Virtualization 3.0.1.0 : php (EulerOS-SA-2019-1544)NessusHuawei Local Security Checks
critical
98868PHP 7.2.x < 7.2.5 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98860PHP 7.1.x < 7.1.17 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98849PHP 7.0.x < 7.0.30 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98826PHP 5.6.x < 5.6.36 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
120886Fedora 28 : php (2018-ee6707d519)NessusFedora Local Security Checks
high
120023SUSE SLES12 Security Update : php5 (SUSE-SU-2018:1291-1)NessusSuSE Local Security Checks
medium
120021SUSE SLES12 Security Update : php7 (SUSE-SU-2018:1176-1)NessusSuSE Local Security Checks
medium
119320GLSA-201812-01 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
118413EulerOS Virtualization 2.5.1 : php (EulerOS-SA-2018-1325)NessusHuawei Local Security Checks
high
117672Tenable SecurityCenter < 5.7.1 Multiple Vulnerabilities (TNS-2018-12)NessusMisc.
critical
111644EulerOS 2.0 SP3 : php (EulerOS-SA-2018-1224)NessusHuawei Local Security Checks
high
110928Debian DSA-4240-1 : php7.0 - security updateNessusDebian Local Security Checks
critical
110881EulerOS 2.0 SP2 : php (EulerOS-SA-2018-1217)NessusHuawei Local Security Checks
high
110697Debian DLA-1397-1 : php5 security updateNessusDebian Local Security Checks
critical
109878openSUSE Security Update : php5 (openSUSE-2018-465)NessusSuSE Local Security Checks
high
109871Slackware 14.0 / 14.1 / 14.2 : php (SSA:2018-136-02)NessusSlackware Local Security Checks
high
109860SUSE SLES11 Security Update : php53 (SUSE-SU-2018:1294-1)NessusSuSE Local Security Checks
high
109812Ubuntu 14.04 LTS / 16.04 LTS / 17.10 / 18.04 LTS : PHP vulnerabilities (USN-3646-1)NessusUbuntu Local Security Checks
high
109714openSUSE Security Update : php7 (openSUSE-2018-441)NessusSuSE Local Security Checks
high
109701Amazon Linux AMI : php56 / php70,php71 (ALAS-2018-1019)NessusAmazon Linux Local Security Checks
high
109657Debian DLA-1373-1 : php5 security updateNessusDebian Local Security Checks
high
109579PHP 7.2.x < 7.2.5 Stack Buffer OverflowNessusCGI abuses
high
109578PHP 7.1.x < 7.1.17 Multiple VulnerabilitiesNessusCGI abuses
high
109577PHP 7.0.x < 7.0.30 Multiple VulnerabilitiesNessusCGI abuses
high
109576PHP 5.6.x < 5.6.36 Multiple VulnerabilitiesNessusCGI abuses
high
109560Fedora 26 : php (2018-6071a600e8)NessusFedora Local Security Checks
high
109559Fedora 27 : php (2018-04f6056c42)NessusFedora Local Security Checks
high