PHP 7.1.x < 7.1.17 Multiple Vulnerabilities

Medium Web Application Scanning Plugin ID 98860

Synopsis

PHP 7.1.x < 7.1.17 Multiple Vulnerabilities

Description

According to its banner, the version of PHP running on the remote web server is 7.1.x prior to 7.1.17. It is, therefore, affected by multiple vulnerabilities.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.1.17 or later.

See Also

http://php.net/ChangeLog-7.php#7.1.17

Plugin Details

Severity: Medium

ID: 98860

Type: remote

Published: 2019/01/09

Updated: 2019/04/10

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2018/04/26

Vulnerability Publication Date: 2018/04/26

Reference Information

CVE: CVE-2018-10545, CVE-2018-10546, CVE-2018-10547, CVE-2018-10548, CVE-2018-10549

BID: 104019, 104020, 104022

CWE: 200, 400, 79, 476, 125

WASC: Information Leakage, Denial of Service, Cross-Site Scripting

OWASP: 2010-A2, 2010-A6, 2013-A3, 2013-A5, 2013-A9, 2017-A6, 2017-A7, 2017-A9