WordPress 5.2.x < 5.2.5 Multiple Vulnerabilities

medium Web Application Scanning Plugin ID 98799
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

WordPress 5.2.x < 5.2.5 Multiple Vulnerabilities

Description

According to its self-reported version number, the detected WordPress application is affected by multiple vulnerabilities :

- Two cross-site scripting (XSS) vulnerabilities exist due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit these, by convincing a user to click a specially crafted URL, to execute arbitrary script code in a user's browser session.

- A remote, authenticated, unprivileged user can make a post sticky via the REST API.

- wp_kses_bad_protcol() has been hardened to ensure that it is aware of the named colon attribute.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update to WordPress version 5.2.5 or latest.

See Also

https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/

https://wordpress.org/support/wordpress-version/version-5-2-5/

Plugin Details

Severity: Medium

ID: 98799

Type: remote

Published: 1/8/2020

Updated: 9/7/2021

Scan Template: api, scan, pci

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 12/27/2019

Vulnerability Publication Date: 12/27/2019

Reference Information

CVE: CVE-2019-20042