CVE-2019-20042

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In wp-includes/formatting.php in WordPress 3.7 to 5.3.0, the function wp_targeted_link_rel() can be used in a particular way to result in a stored cross-site scripting (XSS) vulnerability. This has been patched in WordPress 5.3.1, along with all the previous WordPress versions from 3.7 to 5.3 via a minor release.

References

https://blog.ripstech.com/filter/vulnerabilities/

https://core.trac.wordpress.org/changeset/46894/trunk

https://github.com/WordPress/wordpress-develop/commit/1f7f3f1f59567e2504f0fbebd51ccf004b3ccb1d

https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-xvg2-m2f4-83m7

https://hackerone.com/reports/509930

https://seclists.org/bugtraq/2020/Jan/8

https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/

https://wpvulndb.com/vulnerabilities/9975

https://www.debian.org/security/2020/dsa-4599

Details

Source: MITRE

Published: 2019-12-27

Updated: 2020-01-10

Type: CWE-79

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 6.1

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Impact Score: 2.7

Exploitability Score: 2.8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*

Tenable Plugins

View all (20 total)

IDNameProductFamilySeverity
136373Debian DSA-4677-1 : wordpress - security updateNessusDebian Local Security Checks
critical
132736Debian DSA-4599-1 : wordpress - security updateNessusDebian Local Security Checks
critical
98885WordPress 5.3.x < 5.3.1 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
98799WordPress 5.2.x < 5.2.5 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
98798WordPress 5.1.x < 5.1.4 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
98797WordPress 5.0.x < 5.0.8 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
98796WordPress 4.9.x < 4.9.13 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
98795WordPress 4.8.x < 4.8.12 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
98794WordPress 4.7.x < 4.7.16 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
98793WordPress 4.6.x < 4.6.17 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
98792WordPress 4.5.x < 4.5.20 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
98791WordPress 4.4.x < 4.4.21 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
98790WordPress 4.3.x < 4.3.22 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
98789WordPress 4.2.x < 4.2.26 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
98788WordPress 4.1.x < 4.1.29 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
98787WordPress 4.0.x < 4.0.29 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
98786WordPress 3.9.x < 3.9.30 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
98785WordPress 3.8.x < 3.8.32 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
98784WordPress 3.7.x < 3.7.32 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
medium
132099WordPress < 5.3.1NessusCGI abuses
medium