Apache 2.4.x < 2.4.41 Multiple Vulnerabilities

critical Web App Scanning Plugin ID 98669



Apache 2.4.x < 2.4.41 Multiple Vulnerabilities


According to its banner, the version of Apache running on the remote host is 2.4.x prior to 2.4.41. It is, therefore, affected by multiple vulnerabilities:

- A cross-site scripting (XSS) vulnerability exists in mod_proxy when proxying is enabled and Proxy Error page is displayed. (CVE-2019-10092)

- An open redirect vulnerability exists in mod_rewrite when using self-referential redirects. (CVE-2019-10098)

- A read-after-free vulnerability exists in mod_http2 during connection shutdown. (CVE-2019-10082)

- A memory corruption vulnerability exists in mod_http2 on early pushes. (CVE-2019-10081)

- A denial of service (DoS) vulnerability exists in mod_http2 by exhausting h2 workers. (CVE-2019-9517)

- A stack buffer overflow and NULL pointer dereference vulnerabilities exist in mod_remoteip when using a specially crafted PROXY header. (CVE-2019-10097)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache version 2.4.41 or later.

See Also



Plugin Details

Severity: Critical

ID: 98669

Type: remote

Published: 8/20/2019

Updated: 3/14/2023

Scan Template: api, basic, full, pci, scan

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: High

Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2019-9517


Risk Factor: Critical

Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

CVSS Score Source: CVE-2019-10082

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 9/26/2019

Vulnerability Publication Date: 9/26/2019

Reference Information

CVE: CVE-2019-10081, CVE-2019-10082, CVE-2019-10092, CVE-2019-10097, CVE-2019-10098, CVE-2019-9517