Atlassian Confluence < 6.6.12 Multiple Vulnerabilities

Critical Web Application Scanning Plugin ID 98641

Synopsis

Atlassian Confluence < 6.6.12 Multiple Vulnerabilities

Description

According to its self-reported version number, the Atlassian Confluence application running on the remote host is prior to 6.6.12, 6.7.x prior to 6.12.3, 6.13.x prior to 6.13.3, or 6.14.x prior to 6.14.2. It is, therefore, affected by the following vulnerabilities :

- A server-side request forgery (SSRF) exists in the WebDAV plugin due to improper input validation. An attacker can exploit this, via unspecified vectors, to send arbitrary HTTP and WebDAV requests from the application. (CVE-2019-3395)

- A server-side template injection exists in the Widget Connector due to improper input validation. An attacker can exploit this, via unspecified vectors, to traverse directories or execute arbitrary code. (CVE-2019-3396)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Atlassian Confluence version 6.6.12 or later.

See Also

https://confluence.atlassian.com/doc/confluence-security-advisory-2019-03-20-966660264.html

Plugin Details

Severity: Critical

ID: 98641

Type: remote

Published: 2019/07/17

Updated: 2019/07/17

Scan Template: api, scan, pci

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:atlassian:confluence:*:*:*:*:*:*:*:*

Exploit Available: true

Patch Publication Date: 2019/03/20

Vulnerability Publication Date: 2019/03/20

Reference Information

CVE: CVE-2019-3395, CVE-2019-3396

BID: 107543