CVE-2019-3396

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The Widget Connector macro in Atlassian Confluence Server before version 6.6.12 (the fixed version for 6.6.x), from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from version 6.13.0 before 6.13.3 (the fixed version for 6.13.x), and from version 6.14.0 before 6.14.2 (the fixed version for 6.14.x), allows remote attackers to achieve path traversal and remote code execution on a Confluence Server or Data Center instance via server-side template injection.

References

http://packetstormsecurity.com/files/152568/Atlassian-Confluence-Widget-Connector-Macro-Velocity-Template-Injection.html

http://packetstormsecurity.com/files/161065/Atlassian-Confluence-6.12.1-Template-Injection.html

http://www.rapid7.com/db/modules/exploit/multi/http/confluence_widget_connector

https://jira.atlassian.com/browse/CONFSERVER-57974

https://www.exploit-db.com/exploits/46731/

Details

Source: MITRE

Published: 2019-03-25

Updated: 2021-02-09

Type: CWE-22

Risk Information

CVSS v2

Base Score: 10

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (8 total)

IDNameProductFamilySeverity
98641Atlassian Confluence < 6.6.12 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98640Atlassian Confluence 6.7.x < 6.12.3 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98639Atlassian Confluence 6.13.x < 6.13.3 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98638Atlassian Confluence 6.14.x < 6.14.2 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98613Atlassian Confluence < 6.6.12 / 6.7.x < 6.12.3 / 6.13.x < 6.13.3 / 6.14.x < 6.14.2 Template InjectionWeb Application ScanningComponent Vulnerability
critical
700661Atlassian Confluence < 6.6.12 / 6.7.x < 6.12.3 / 6.13.x < 6.13.3 / 6.14.x < 6.14.2 Multiple VulnerabilitiesNessus Network MonitorCGI
critical
124004Atlassian Confluence < 6.6.12 / 6.7.x < 6.12.3 / 6.13.x < 6.13.3 / 6.14.x < 6.14.2 Template InjectionNessusCGI abuses
critical
123008Atlassian Confluence < 6.6.12 / 6.7.x < 6.12.3 / 6.13.x < 6.13.3 / 6.14.x < 6.14.2 Multiple VulnerabilitiesNessusCGI abuses
critical