PHP 7.1.x < 7.1.29 Heap-based Buffer Overflow Vulnerability

critical Web Application Scanning Plugin ID 98601
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

PHP 7.1.x < 7.1.29 Heap-based Buffer Overflow Vulnerability

Description

According to its banner, the version of PHP running on the remote web server is 7.1.x prior to 7.1.29, 7.2.x prior to 7.2.18 or 7.3.x prior to 7.3.5. It is, therefore, affected by a heap-based buffer over-read condition within _estrndup of the exif_process_IFD_TAG in the exif.c script. An unauthenticated, remote attacker can exploit this, to cause a denial of service condition or the execution of arbitrary code.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.1.29 or later.

See Also

https://php.net/ChangeLog-7.php#7.1.29

https://www.php.net/index.php#id2019-05-03-1

Plugin Details

Severity: Critical

ID: 98601

Type: remote

Published: 5/22/2019

Updated: 9/7/2021

Scan Template: api, scan, pci

Risk Information

CVSS Score Source: CVE-2019-11036

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:P

CVSS v3

Risk Factor: Critical

Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 5/3/2019

Vulnerability Publication Date: 5/3/2019

Reference Information

CVE: CVE-2019-11036