CVE-2019-11036

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

When processing certain files, PHP EXIF extension in versions 7.1.x below 7.1.29, 7.2.x below 7.2.18 and 7.3.x below 7.3.5 can be caused to read past allocated buffer in exif_process_IFD_TAG function. This may lead to information disclosure or crash.

References

http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00010.html

http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00012.html

http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html

http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html

http://www.securityfocus.com/bid/108177

https://access.redhat.com/errata/RHSA-2019:2519

https://access.redhat.com/errata/RHSA-2019:3299

https://bugs.php.net/bug.php?id=77950

https://lists.debian.org/debian-lts-announce/2019/05/msg00035.html

https://lists.fedoraproject.org/archives/list/[email protected]/message/2NFXYNCXZCPYT7ZN4ZLI5EPQQW44FRRO/

https://lists.fedoraproject.org/archives/list/[email protected]/message/3BY2XUUAN277LS7HKAOGL4DVGAELOJV3/

https://lists.fedoraproject.org/archives/list/[email protected]/message/WN2HLPGEZEF4MFM5YC5FILZB5QEQFP3A/

https://seclists.org/bugtraq/2019/Sep/35

https://seclists.org/bugtraq/2019/Sep/38

https://security.netapp.com/advisory/ntap-20190517-0003/

https://usn.ubuntu.com/3566-2/

https://usn.ubuntu.com/4009-1/

https://www.debian.org/security/2019/dsa-4527

https://www.debian.org/security/2019/dsa-4529

Details

Source: MITRE

Published: 2019-05-03

Updated: 2020-10-02

Type: CWE-125

Risk Information

CVSS v2

Base Score: 6.4

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:P

Impact Score: 4.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 9.1

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Impact Score: 5.2

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (28 total)

IDNameProductFamilySeverity
145814CentOS 8 : php:7.2 (CESA-2020:1624)NessusCentOS Local Security Checks
critical
142352EulerOS 2.0 SP2 : php (EulerOS-SA-2020-2384)NessusHuawei Local Security Checks
critical
140834EulerOS 2.0 SP3 : php (EulerOS-SA-2020-2067)NessusHuawei Local Security Checks
critical
136057RHEL 8 : php:7.2 (RHSA-2020:1624)NessusRed Hat Local Security Checks
critical
129107Debian DSA-4529-1 : php7.0 - security updateNessusDebian Local Security Checks
critical
129073Debian DSA-4527-1 : php7.3 - security updateNessusDebian Local Security Checks
critical
126282EulerOS 2.0 SP8 : php (EulerOS-SA-2019-1655)NessusHuawei Local Security Checks
critical
126035openSUSE Security Update : php7 (openSUSE-2019-1573)NessusSuSE Local Security Checks
critical
126034openSUSE Security Update : php7 (openSUSE-2019-1572)NessusSuSE Local Security Checks
critical
125904Amazon Linux AMI : php71 / php72,php73 (ALAS-2019-1225)NessusAmazon Linux Local Security Checks
critical
125850SUSE SLED15 / SLES15 Security Update : php7 (SUSE-SU-2019:1461-1)NessusSuSE Local Security Checks
critical
125769Ubuntu 16.04 LTS / 18.04 LTS / 18.10 / 19.04 : php7.0, php7.2 vulnerabilities (USN-4009-1)NessusUbuntu Local Security Checks
critical
125700openSUSE Security Update : php5 (openSUSE-2019-1503)NessusSuSE Local Security Checks
high
125699openSUSE Security Update : php7 (openSUSE-2019-1501)NessusSuSE Local Security Checks
critical
125538SUSE SLES12 Security Update : php7 (SUSE-SU-2019:1365-1)NessusSuSE Local Security Checks
critical
125471SUSE SLES12 Security Update : php72 (SUSE-SU-2019:1360-1)NessusSuSE Local Security Checks
critical
125457SUSE SLES12 Security Update : php5 (SUSE-SU-2019:1325-1)NessusSuSE Local Security Checks
high
125409Debian DLA-1803-1 : php5 security updateNessusDebian Local Security Checks
critical
125352Ubuntu 14.04 LTS : PHP vulnerabilities (USN-3566-2)NessusUbuntu Local Security Checks
critical
98601PHP 7.1.x < 7.1.29 Heap-based Buffer Overflow VulnerabilityWeb Application ScanningComponent Vulnerability
critical
98600PHP 7.2.x < 7.2.18 Heap-based Buffer Overflow VulnerabilityWeb Application ScanningComponent Vulnerability
critical
98599PHP 7.3.x < 7.3.5 Heap-based Buffer Overflow VulnerabilityWeb Application ScanningComponent Vulnerability
critical
124784Fedora 28 : php (2019-bab3944fee)NessusFedora Local Security Checks
critical
124783Fedora 29 : php (2019-6e325234a4)NessusFedora Local Security Checks
critical
124782Fedora 30 : php (2019-6350c4e21a)NessusFedora Local Security Checks
critical
124764PHP 7.3.x < 7.3.5 Heap-based Buffer Overflow Vulnerability.NessusCGI abuses
critical
124763PHP 7.2.x < 7.2.18 Heap-based Buffer Overflow Vulnerability.NessusCGI abuses
critical
124762PHP 7.1.x < 7.1.29 Heap-based Buffer Overflow Vulnerability.NessusCGI abuses
critical