WordPress 3.7.x < 3.7.18 Multiple Vulnerabilities

critical Web Application Scanning Plugin ID 98271

Language:

Synopsis

WordPress 3.7.x < 3.7.18 Multiple Vulnerabilities

Description

According to its self-reported version number, the detected WordPress application is affected by multiple vulnerabilities :

- An information disclosure vulnerability exists in the class-wp-press-this.php script due to a failure to properly restrict the user interface for assigning taxonomy terms. An authenticated, remote attacker can exploit this to disclose sensitive information. (CVE-2017-5610)

- A SQL injection (SQLi) vulnerability exists in the class-wp-query.php script due to a failure to sanitize input to post type names. An unauthenticated, remote attacker can exploit this to inject or manipulate SQL queries in the back-end database, resulting in the disclosure or manipulation of arbitrary data. (CVE-2017-5611)

- A cross-site scripting (XSS) vulnerability exists in the class-wp-posts-list-table.php script due to improper validation of input to the posts list table. An unauthenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session. (CVE-2017-5612)

- A privilege escalation vulnerability exists in the REST API due to a failure to properly sanitize user-supplied input to the 'id' parameter when editing or deleting blog posts. An unauthenticated, remote attacker can exploit this issue to run arbitrary PHP code, inject content into blog posts, modify blog post attributes, or delete blog posts. (CVE-2017-1001000)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update to WordPress version 3.7.18 or latest.

See Also

https://wordpress.org/news/2017/01/wordpress-4-7-2-security-release/

https://codex.wordpress.org/Version_3.7.18

Plugin Details

Severity: Critical

ID: 98271

Type: remote

Published: 11/5/2018

Updated: 10/7/2021

Scan Template: pci, api, scan

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2017-5611

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

CVSS Score Source: CVE-2017-5611

Vulnerability Information

CPE: cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 1/30/2017

Vulnerability Publication Date: 1/30/2017

Reference Information

CVE: CVE-2017-5610, CVE-2017-1001000, CVE-2017-5611, CVE-2017-5612

CWE: 200, 79, 89, 254

WASC: Cross-Site Scripting, Information Leakage, SQL Injection

OWASP: 2010-A2, 2013-A3, 2013-A9, 2017-A7, 2017-A9, 2017-A6, 2013-A5, 2010-A6, 2010-A1, 2013-A1, 2017-A1, 2021-A6, 2021-A1, 2021-A3

OWASP API: 2019-API7, 2019-API8

HIPAA: 164.306(a)(1), 164.306(a)(2)

DISA STIG: APSC-DV-002630, APSC-DV-000460, APSC-DV-002490, APSC-DV-002540

OWASP ASVS: 4.0.2-14.2.1, 4.0.2-8.3.4, 4.0.2-5.3.3, 4.0.2-5.3.4

PCI-DSS: 3.2-6.2, 3.2-6.5.8, 3.2-6.5.7, 3.2-6.5.1

ISO: 27001-A.14.2.5

CAPEC: 116, 13, 169, 22, 224, 285, 287, 290, 291, 292, 293, 294, 295, 296, 297, 298, 299, 300, 301, 302, 303, 304, 305, 306, 307, 308, 309, 310, 312, 313, 317, 318, 319, 320, 321, 322, 323, 324, 325, 326, 327, 328, 329, 330, 472, 497, 508, 573, 574, 575, 576, 577, 59, 60, 616, 643, 646, 651, 79, 209, 588, 591, 592, 63, 85, 108, 109, 110, 7, 470, 66

NIST: sp800_53-CM-6b, sp800_53-SI-10, sp800_53-SI-15