CVE-2017-5611

HIGH

Description

SQL injection vulnerability in wp-includes/class-wp-query.php in WP_Query in WordPress before 4.7.2 allows remote attackers to execute arbitrary SQL commands by leveraging the presence of an affected plugin or theme that mishandles a crafted post type name.

References

http://www.debian.org/security/2017/dsa-3779

http://www.openwall.com/lists/oss-security/2017/01/28/5

http://www.securityfocus.com/bid/95816

http://www.securitytracker.com/id/1037731

https://codex.wordpress.org/Version_4.7.2

https://github.com/WordPress/WordPress/commit/85384297a60900004e27e417eac56d24267054cb

https://wordpress.org/news/2017/01/wordpress-4-7-2-security-release/

https://wpvulndb.com/vulnerabilities/8730

Details

Source: MITRE

Published: 2017-01-30

Updated: 2019-03-19

Type: CWE-89

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL